summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-haskell/crypto/crypto-4.2.5.1-r1.ebuild18
-rw-r--r--dev-haskell/crypto/metadata.xml6
2 files changed, 10 insertions, 14 deletions
diff --git a/dev-haskell/crypto/crypto-4.2.5.1-r1.ebuild b/dev-haskell/crypto/crypto-4.2.5.1-r1.ebuild
index 221307abdb08..f7d2aca9c061 100644
--- a/dev-haskell/crypto/crypto-4.2.5.1-r1.ebuild
+++ b/dev-haskell/crypto/crypto-4.2.5.1-r1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-# ebuild generated by hackport 0.3.9999
+# ebuild generated by hackport 0.6.6.9999
-CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
MY_PN="Crypto"
@@ -21,11 +21,13 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND="dev-haskell/hunit:=[profile?]
- >=dev-haskell/quickcheck-2.4.0.1:2=[profile?]
- dev-haskell/random:=[profile?]
- >=dev-lang/ghc-6.10.4:="
+ >=dev-haskell/quickcheck-2.4.0.1:2=[profile?]
+ dev-haskell/random:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.2"
+ >=dev-haskell/cabal-1.2
+"
S="${WORKDIR}/${MY_P}"
@@ -40,7 +42,7 @@ src_test() {
}
src_install() {
- cabal_src_install
+ haskell-cabal_src_install
rm -rf "${D}/usr/bin" 2>/dev/null
}
diff --git a/dev-haskell/crypto/metadata.xml b/dev-haskell/crypto/metadata.xml
index 2dbebd8cd714..b7878815d80d 100644
--- a/dev-haskell/crypto/metadata.xml
+++ b/dev-haskell/crypto/metadata.xml
@@ -5,10 +5,4 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- DES, Blowfish, AES, TEA, SHA1, MD5, RSA, BubbleBabble,
- Hexdump, Support for Word128, Word192 and Word256 and Beyond, PKCS5
- Padding, Various Encryption Modes e.g. Cipher Block Chaining all in one package,
- with HUnit and QuickCheck tests, and examples.
- </longdescription>
</pkgmetadata>