summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-fps/urbanterror/Manifest1
-rw-r--r--games-fps/urbanterror/files/urbanterror-4.2.023-build.patch75
-rw-r--r--games-fps/urbanterror/files/urbanterror-4.2.023-nocurl.patch16
-rw-r--r--games-fps/urbanterror/urbanterror-4.3.2_p20170713.ebuild152
-rw-r--r--profiles/base/package.use.mask4
-rw-r--r--profiles/package.mask5
-rw-r--r--sys-apps/systemd/metadata.xml2
-rw-r--r--sys-apps/systemd/systemd-234.ebuild2
8 files changed, 159 insertions, 98 deletions
diff --git a/games-fps/urbanterror/Manifest b/games-fps/urbanterror/Manifest
index 6264ada02b54..89c3757cd59b 100644
--- a/games-fps/urbanterror/Manifest
+++ b/games-fps/urbanterror/Manifest
@@ -1 +1,2 @@
DIST urbanterror-4.3.2_p20170426.tar.gz 10058308 SHA256 8009516332e1f77eae3681b436e099fdd42ffa55d2691694eedc0ca94b194878 SHA512 e8107ab44fdb40bc14a548239185905a01120bbe960b8713e5959df18330fd845761350c5e8e5efd5fbfec10ad62ff9fef68420406cc4cfbe2af69ee66eff1f3 WHIRLPOOL 6aac15e44b0695501195ae172133f4b6788b9dffa5442af20d11626ad27ffd597c7f070c0fb95b0e0e8b8b3d6cf0e1bfc40b0a16abaa27c8f932ee90f19a1824
+DIST urbanterror-4.3.2_p20170713.tar.gz 9984763 SHA256 cf1784a3bd00451fe1bda3267235ea3eee93da65880f15fd13c07681952b4859 SHA512 09fd2232c3cbdde001b8d037f2667a55a584378615f2da10c6815797748028f36b75c899ca4fd1d7d97a33f4b3ddbaa4d271b36b5eabf3bf9e81852ef15864a4 WHIRLPOOL 2bed79adc1dc338d74212263105c03bad51391f8c9e9e543ad54f6d6006cea4a8ebfc0e601400338b941d799dc0f642f71478dc68ad84a50718043f06f042290
diff --git a/games-fps/urbanterror/files/urbanterror-4.2.023-build.patch b/games-fps/urbanterror/files/urbanterror-4.2.023-build.patch
deleted file mode 100644
index daa7e324a677..000000000000
--- a/games-fps/urbanterror/files/urbanterror-4.2.023-build.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-Author: hasufell <hasufell@gentoo.org>
-Date: Wed Jul 10 01:25:27 2013 +0200
-
- respect CFLAGS/LDFLAGS
-
---- a/Makefile
-+++ b/Makefile
-@@ -213,7 +213,7 @@
- endif
- endif
-
-- BASE_CFLAGS = -Wall -fno-strict-aliasing -Wimplicit -Wstrict-prototypes -pipe
-+ BASE_CFLAGS = -Wall -Wimplicit -Wstrict-prototypes
-
- ifeq ($(USE_OPENAL),1)
- BASE_CFLAGS += -DUSE_OPENAL=1
-@@ -239,19 +239,15 @@
- BASE_CFLAGS += -I/usr/X11R6/include
- endif
-
-- OPTIMIZE = -O3 -ffast-math -funroll-loops -fomit-frame-pointer
-+ OPTIMIZE =
-
- ifeq ($(ARCH),x86_64)
-- OPTIMIZE = -O3 -fomit-frame-pointer -ffast-math -funroll-loops \
-- -falign-loops=2 -falign-jumps=2 -falign-functions=2 \
-- -fstrength-reduce
-+ OPTIMIZE =
- # experimental x86_64 jit compiler! you need GNU as
- HAVE_VM_COMPILED = true
- else
- ifeq ($(ARCH),i386)
-- OPTIMIZE = -O3 -march=i586 -fomit-frame-pointer -ffast-math \
-- -funroll-loops -falign-loops=2 -falign-jumps=2 \
-- -falign-functions=2 -fstrength-reduce
-+ OPTIMIZE =
- HAVE_VM_COMPILED=true
- else
- ifeq ($(ARCH),ppc)
-@@ -265,7 +261,7 @@
- BASE_CFLAGS += -DNO_VM_COMPILED
- endif
-
-- DEBUG_CFLAGS = $(BASE_CFLAGS) -g -O0
-+ DEBUG_CFLAGS = $(BASE_CFLAGS) $(OPTIMIZE)
-
- RELEASE_CFLAGS=$(BASE_CFLAGS) -DNDEBUG $(OPTIMIZE)
-
-@@ -274,7 +270,7 @@
- SHLIBLDFLAGS=-shared $(LDFLAGS)
-
- THREAD_LDFLAGS=-lpthread
-- LDFLAGS=-ldl -lm
-+ LDFLAGS+=-ldl -lm
-
- ifeq ($(USE_SDL),1)
- CLIENT_LDFLAGS=$(shell sdl-config --libs)
-@@ -1158,13 +1154,13 @@
-
- $(B)/Quake3-UrT.$(ARCH)$(BINEXT): $(Q3OBJ) $(Q3POBJ) $(LIBSDLMAIN)
- $(echo_cmd) "LD $@"
-- $(Q)$(CC) -o $@ $(Q3OBJ) $(Q3POBJ) $(CLIENT_LDFLAGS) \
-- $(LDFLAGS) $(LIBSDLMAIN)
-+ $(Q)$(CC) $(CFLAGS) -o $@ $(Q3OBJ) $(Q3POBJ) \
-+ $(LDFLAGS) $(CLIENT_LDFLAGS) $(LIBSDLMAIN)
-
- $(B)/Quake3-UrT-smp.$(ARCH)$(BINEXT): $(Q3OBJ) $(Q3POBJ_SMP) $(LIBSDLMAIN)
- $(echo_cmd) "LD $@"
-- $(Q)$(CC) -o $@ $(Q3OBJ) $(Q3POBJ_SMP) $(CLIENT_LDFLAGS) \
-- $(THREAD_LDFLAGS) $(LDFLAGS) $(LIBSDLMAIN)
-+ $(Q)$(CC) $(CFLAGS) -o $@ $(Q3OBJ) $(Q3POBJ_SMP) \
-+ $(LDFLAGS) $(THREAD_LDFLAGS) $(CLIENT_LDFLAGS) $(LIBSDLMAIN)
-
- ifneq ($(strip $(LIBSDLMAIN)),)
- ifneq ($(strip $(LIBSDLMAINSRC)),)
diff --git a/games-fps/urbanterror/files/urbanterror-4.2.023-nocurl.patch b/games-fps/urbanterror/files/urbanterror-4.2.023-nocurl.patch
deleted file mode 100644
index b7d1f3106420..000000000000
--- a/games-fps/urbanterror/files/urbanterror-4.2.023-nocurl.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-fix building when USE=-curl is specified (bug #572074)
-
---- ./code/client/cl_main.c.orig
-+++ ./code/client/cl_main.c
-@@ -1872,7 +1872,11 @@
- }
-
- qboolean CL_IsDownloading(void) {
-+#if USE_CURL
- return clc.cURLUsed;
-+#else
-+ return qfalse;
-+#endif
- }
-
- /*
diff --git a/games-fps/urbanterror/urbanterror-4.3.2_p20170713.ebuild b/games-fps/urbanterror/urbanterror-4.3.2_p20170713.ebuild
new file mode 100644
index 000000000000..d608be174efe
--- /dev/null
+++ b/games-fps/urbanterror/urbanterror-4.3.2_p20170713.ebuild
@@ -0,0 +1,152 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+inherit flag-o-matic gnome2-utils
+
+DESCRIPTION="Hollywood tactical shooter based on the ioquake3 engine"
+HOMEPAGE="http://urbanterror.info"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mickael9/ioq3.git"
+ EGIT_BRANCH="urt"
+else
+ COMMIT_ID="8eb3e10163c62331b77171a71ca6102d3d63c3e7"
+ SRC_URI="https://github.com/mickael9/ioq3/archive/${COMMIT_ID}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/ioq3-${COMMIT_ID}"
+ KEYWORDS="~amd64 ~x86"
+
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+altgamma +client +curl debug mumble openal +opus server voip vorbis"
+REQUIRED_USE=" || ( client server )"
+
+PATCHES=( "${FILESDIR}"/${PN}-4.3-respect_CFLAGS.patch )
+
+RDEPEND="
+ client? (
+ media-libs/libsdl2[X,sound,joystick,opengl,video]
+ mumble? ( media-sound/mumble )
+ openal? ( media-libs/openal )
+ opus? ( media-libs/opusfile )
+ vorbis? (
+ media-libs/libogg
+ media-libs/libvorbis
+ )
+ )
+ curl? ( net-misc/curl )
+ ~games-fps/urbanterror-data-4.3.2
+ sys-libs/zlib[minizip]
+ virtual/jpeg:0
+"
+
+DEPEND="${RDEPEND}"
+
+pkg_pretend() {
+ if use client; then
+ if ! use openal && ! use opus && ! use vorbis; then
+ ewarn
+ ewarn "No sound implementation selected. Enable 'openal', 'opus' or 'vorbis' USE flag to get sound!"
+ fi
+ fi
+}
+
+src_compile() {
+ buildit() { use $1 && echo 1 || echo 0 ; }
+ nobuildit() { use $1 && echo 0 || echo 1 ; }
+
+ # Workaround for used zlib macro, wrt bug #44951
+ append-flags "-DOF=_Z_OF"
+
+ emake \
+ ARCH=$(usex amd64 "x86_64" "i386") \
+ DEFAULT_BASEDIR="/usr/share/urbanterror" \
+ BUILD_CLIENT=$(buildit client) \
+ BUILD_SERVER=$(buildit server) \
+ BUILD_BASEGAME=1 \
+ BUILD_MISSIONPACK=0 \
+ BUILD_GAME_SO=0 \
+ BUILD_GAME_QVM=0 \
+ BUILD_STANDALONE=1 \
+ SERVERBIN="Quake3-UrT-Ded" \
+ CLIENTBIN="Quake3-UrT" \
+ USE_RENDERER_DLOPEN=0 \
+ USE_YACC=0 \
+ BASEGAME="q3ut4"\
+ BASEGAME_CFLAGS="${CFLAGS}" \
+ USE_OPENAL=$(buildit openal) \
+ USE_OPENAL_DLOPEN=$(buildit openal) \
+ USE_CURL=$(buildit curl) \
+ USE_CURL_DLOPEN=$(buildit curl) \
+ USE_CODEC_VORBIS=$(buildit vorbis) \
+ USE_CODEC_OPUS=$(buildit opus) \
+ USE_MUMBLE=$(buildit mumble) \
+ USE_VOIP=$(buildit voip) \
+ USE_INTERNAL_LIBS=0 \
+ USE_LOCAL_HEADERS=0 \
+ USE_ALTGAMMA=$(buildit altgamma)
+}
+
+src_install() {
+ local my_arch=$(usex amd64 "x86_64" "i386")
+
+ # docs from ioq3, not from UrbanTerror ZIP file
+ dodoc ChangeLog README.md README.ioq3.md md4-readme.txt
+
+ if use client; then
+ newbin build/$(usex debug "debug" "release")-linux-${my_arch}/Quake3-UrT.${my_arch} ${PN}
+ # Shooter as defined in https://specifications.freedesktop.org/menu-spec/latest/apas02.html
+ make_desktop_entry ${PN} "UrbanTerror" ${PN}
+ fi
+
+ if use server && ! use client; then
+ # dedicated server only
+ newbin build/$(usex debug "debug" "release")-linux-${my_arch}/Quake3-UrT-Ded.${my_arch} ${PN}-ded
+ fi
+}
+
+pkg_preinst() {
+ use client && gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ use client && gnome2_icon_cache_update
+
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+ if use openal; then
+ elog ""
+ elog "You might need to set:"
+ elog " seta s_useopenal \"1\""
+ elog "in your ~/.q3a/q3ut4/q3config.cfg for openal to work."
+ fi
+
+ if use altgamma; then
+ elog ""
+ elog "You might need to set:"
+ elog " seta r_altgamma \"1\""
+ elog "in your ~/.q3a/q3ut4/q3config.cfg for altgamma to work."
+ fi
+
+ if ! use altgamma; then
+ elog ""
+ elog "If you are using a modesetting graphics driver you might"
+ elog "consider setting USE=\"altgamma\"."
+ elog "For details take a look at:"
+ elog "https://bugs.freedesktop.org/show_bug.cgi?id=27222"
+ fi
+ if ! use client; then
+ elog ""
+ elog "You disabled client support. You won't be able to connect"
+ elog "to any servers and play. If you want to do so, enable"
+ elog "USE=\"client\"."
+ fi
+ fi
+}
+
+pkg_postrm() {
+ use client && gnome2_icon_cache_update
+}
diff --git a/profiles/base/package.use.mask b/profiles/base/package.use.mask
index 6a02be3424d0..8fae51407a92 100644
--- a/profiles/base/package.use.mask
+++ b/profiles/base/package.use.mask
@@ -7,6 +7,10 @@
# This file is only for generic masks. For arch-specific masks (i.e.
# mask everywhere, unmask on arch/*) use arch/base.
+# Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org> (16 Jul 2017)
+# Causes build to fail with ffmpeg-3, #602786
+www-plugins/gnash vaapi
+
# Pacho Ramos <pacho@gentoo.org> (14 Jul 2017)
# system-renpy cannot be really used and it's going to be treecleaned, bug #587872
games-misc/katawa-shoujo system-renpy
diff --git a/profiles/package.mask b/profiles/package.mask
index e6cceffcd3c3..8a648aa3e10b 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -423,11 +423,6 @@ app-emulation/vmware-modules
app-emulation/vmware-tools
# Pacho Ramos <pacho@gentoo.org> (17 Jun 2017)
-# Not compatible with ffmpeg-3 (#602786), other bug reports and NPAPI
-# plugins support in main browsers is dying. Removal in a month.
-www-plugins/gnash
-
-# Pacho Ramos <pacho@gentoo.org> (17 Jun 2017)
# Not compatible with ffmpeg-3 (#589806) and needs vulnerable qtwebkit:4
# (#620740). Removal in a month.
net-voip/homer
diff --git a/sys-apps/systemd/metadata.xml b/sys-apps/systemd/metadata.xml
index 922bac04c722..0ff06358a67a 100644
--- a/sys-apps/systemd/metadata.xml
+++ b/sys-apps/systemd/metadata.xml
@@ -29,7 +29,7 @@
<flag name="qrcode">Enable qrcode output support in journal</flag>
<flag name="sysv-utils">Install sysvinit compatibility symlinks and manpages for init, telinit, halt, poweroff, reboot, runlevel, and shutdown</flag>
<flag name="vanilla">Disable Gentoo-specific behavior and compatibility quirks</flag>
- <flag name="xkb">Validate XKB keymap in logind</flag>
+ <flag name="xkb">Depend on <pkg>x11-libs/libxkbcommon</pkg> to allow logind to control the X11 keymap</flag>
</use>
<upstream>
<remote-id type="github">systemd/systemd</remote-id>
diff --git a/sys-apps/systemd/systemd-234.ebuild b/sys-apps/systemd/systemd-234.ebuild
index 86fb33dc3169..26139f10999c 100644
--- a/sys-apps/systemd/systemd-234.ebuild
+++ b/sys-apps/systemd/systemd-234.ebuild
@@ -8,7 +8,7 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
else
SRC_URI="https://github.com/systemd/systemd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- #KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64 ~x86"
fi
PYTHON_COMPAT=( python{3_4,3_5,3_6} )