summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--eclass/ant-tasks.eclass1
-rw-r--r--eclass/java-utils-2.eclass11
-rw-r--r--eclass/mozextension.eclass9
-rw-r--r--eclass/openib.eclass6
-rw-r--r--eclass/php-pear-r2.eclass3
-rw-r--r--eclass/portability.eclass2
-rw-r--r--eclass/postgres-multi.eclass3
-rw-r--r--eclass/postgres.eclass3
-rw-r--r--eclass/ssl-cert.eclass1
-rw-r--r--eclass/stardict.eclass15
-rw-r--r--eclass/toolchain.eclass8
-rw-r--r--eclass/vim-doc.eclass7
-rw-r--r--gui-libs/wayfire-plugins-extra/Manifest1
-rw-r--r--gui-libs/wayfire-plugins-extra/metadata.xml12
-rw-r--r--gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-0.6.0.ebuild33
-rw-r--r--gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-9999.ebuild33
-rw-r--r--gui-wm/hikari/hikari-2.2.2-r1.ebuild (renamed from gui-wm/hikari/hikari-2.2.2.ebuild)6
17 files changed, 129 insertions, 25 deletions
diff --git a/eclass/ant-tasks.eclass b/eclass/ant-tasks.eclass
index c882196e7758..a96222f8ff50 100644
--- a/eclass/ant-tasks.eclass
+++ b/eclass/ant-tasks.eclass
@@ -66,6 +66,7 @@ ANT_TASK_DEPNAME=${ANT_TASK_DEPNAME-${ANT_TASK_NAME}}
# @VARIABLE: ANT_TASK_PV
# @INTERNAL
+# @DESCRIPTION:
# Version of ant-core this task is intended to register and thus load with.
ANT_TASK_PV="${PV}"
diff --git a/eclass/java-utils-2.eclass b/eclass/java-utils-2.eclass
index a33962f114de..84c09885c7ba 100644
--- a/eclass/java-utils-2.eclass
+++ b/eclass/java-utils-2.eclass
@@ -1484,7 +1484,6 @@ java-pkg_ensure-vm-version-sufficient() {
# @FUNCTION: java-pkg_is-vm-version-sufficient
# @INTERNAL
-# @DESCRIPTION:
# @RETURN: zero - VM is sufficient; non-zero - VM is not sufficient
java-pkg_is-vm-version-sufficient() {
debug-print-function ${FUNCNAME} $*
@@ -1564,8 +1563,8 @@ java-pkg_ensure-vm-version-ge() {
# Parameters:
# $@ - VM version to compare current VM to
# @CODE
-# @RETURN: zero - current VM version is greater than checked version;
-# non-zero - current VM version is not greater than checked version
+# @RETURN: zero - current VM version is greater than checked version
+# @RETURN: non-zero - current VM version is not greater than checked version
java-pkg_is-vm-version-ge() {
debug-print-function ${FUNCNAME} $*
@@ -2592,14 +2591,14 @@ java-pkg_needs-vm() {
# @FUNCTION: java-pkg_get-current-vm
# @INTERNAL
-# @RETURN - The current VM being used
+# @RETURN: The current VM being used
java-pkg_get-current-vm() {
java-config -f
}
# @FUNCTION: java-pkg_get-vm-vendor
# @INTERNAL
-# @RETURN - The vendor of the current VM
+# @RETURN: The vendor of the current VM
java-pkg_get-vm-vendor() {
debug-print-function ${FUNCNAME} $*
@@ -2610,7 +2609,7 @@ java-pkg_get-vm-vendor() {
# @FUNCTION: java-pkg_get-vm-version
# @INTERNAL
-# @RETURN - The version of the current VM
+# @RETURN: The version of the current VM
java-pkg_get-vm-version() {
debug-print-function ${FUNCNAME} $*
diff --git a/eclass/mozextension.eclass b/eclass/mozextension.eclass
index ea4f1eb143e9..ab7d56d24ce9 100644
--- a/eclass/mozextension.eclass
+++ b/eclass/mozextension.eclass
@@ -5,7 +5,7 @@
# @MAINTAINER:
# Mozilla team <mozilla@gentoo.org>
# @BLURB: Install extensions for use in mozilla products.
-#
+
if [[ ! ${_MOZEXTENSION} ]]; then
# @ECLASS-VARIABLE: MOZEXTENSION_TARGET
@@ -20,6 +20,8 @@ inherit eutils
DEPEND="app-arch/unzip"
+# @FUNCTION: mozversion_extension_location
+
mozversion_extension_location() {
case ${PN} in
firefox|firefox-bin|palemoon)
@@ -32,6 +34,8 @@ mozversion_extension_location() {
return 1
}
+# @FUNCTION: xpi_unpack
+
xpi_unpack() {
local xpi xpiname srcdir
@@ -61,6 +65,7 @@ xpi_unpack() {
done
}
+# @FUNCTION: xpi_install
xpi_install() {
local emid
@@ -91,6 +96,8 @@ xpi_install() {
doins -r "${x}"/* || die "failed to copy extension"
}
+# @FUNCTION: xpi_copy
+
xpi_copy() {
local emid
diff --git a/eclass/openib.eclass b/eclass/openib.eclass
index 08d6fb3a1115..685eaf344a7e 100644
--- a/eclass/openib.eclass
+++ b/eclass/openib.eclass
@@ -1,9 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: openib.eclass
+# @MAINTAINER:
+# maintainer-needed@gentoo.org
# @AUTHOR:
-# Original Author: Alexey Shvetsov <alexxy@gentoo.org>
+# Alexey Shvetsov <alexxy@gentoo.org>
# @BLURB: Simplify working with OFED packages
inherit eutils rpm versionator
diff --git a/eclass/php-pear-r2.eclass b/eclass/php-pear-r2.eclass
index e4197522b162..cd4625fdacc2 100644
--- a/eclass/php-pear-r2.eclass
+++ b/eclass/php-pear-r2.eclass
@@ -39,7 +39,8 @@ RDEPEND=">=dev-php/pear-1.8.1"
# @ECLASS-VARIABLE: PEAR-P
# @INTERNAL
-# @DESCRIPTION: Combines PHP_PEAR_PKG_NAME and PEAR_PV
+# @DESCRIPTION:
+# Combines PHP_PEAR_PKG_NAME and PEAR_PV
PEAR_P="${PHP_PEAR_PKG_NAME}-${PEAR_PV}"
# @ECLASS-VARIABLE: PHP_PEAR_DOMAIN
diff --git a/eclass/portability.eclass b/eclass/portability.eclass
index 1402c0420cb0..67ca30fa5aa4 100644
--- a/eclass/portability.eclass
+++ b/eclass/portability.eclass
@@ -13,7 +13,6 @@ _PORTABILITY_ECLASS=1
# @FUNCTION: treecopy
# @USAGE: <orig1> [orig2 orig3 ....] <dest>
-# @RETURN:
# @DESCRIPTION:
# mimic cp --parents copy, but working on BSD userland as well
treecopy() {
@@ -118,7 +117,6 @@ get_bmake() {
# @FUNCTION: get_mounts
# @USAGE:
# @RETURN: table of mounts in form "point node fs opts"
-# @MAINTAINER:
# @DESCRIPTION:
# Portable method of getting mount names and points.
# Returns as "point node fs options"
diff --git a/eclass/postgres-multi.eclass b/eclass/postgres-multi.eclass
index 49d5c6a9c684..76916932042d 100644
--- a/eclass/postgres-multi.eclass
+++ b/eclass/postgres-multi.eclass
@@ -8,7 +8,8 @@ EXPORT_FUNCTIONS pkg_setup src_prepare src_compile src_install src_test
# @ECLASS: postgres-multi.eclass
# @MAINTAINER:
# PostgreSQL <pgsql-bugs@gentoo.org>
-# @AUTHOR: Aaron W. Swenson <titanofold@gentoo.org>
+# @AUTHOR:
+# Aaron W. Swenson <titanofold@gentoo.org>
# @SUPPORTED_EAPIS: 5 6 7
# @BLURB: An eclass to build PostgreSQL-related packages against multiple slots
# @DESCRIPTION:
diff --git a/eclass/postgres.eclass b/eclass/postgres.eclass
index 2e2ac85ead6f..b7b45fd888d4 100644
--- a/eclass/postgres.eclass
+++ b/eclass/postgres.eclass
@@ -7,7 +7,8 @@ EXPORT_FUNCTIONS pkg_setup
# @ECLASS: postgres.eclass
# @MAINTAINER:
# PostgreSQL <pgsql-bugs@gentoo.org>
-# @AUTHOR: Aaron W. Swenson <titanofold@gentoo.org>
+# @AUTHOR:
+# Aaron W. Swenson <titanofold@gentoo.org>
# @SUPPORTED_EAPIS: 5 6 7
# @BLURB: An eclass for PostgreSQL-related packages
# @DESCRIPTION:
diff --git a/eclass/ssl-cert.eclass b/eclass/ssl-cert.eclass
index 0e7294f62299..a9a6c820e960 100644
--- a/eclass/ssl-cert.eclass
+++ b/eclass/ssl-cert.eclass
@@ -3,6 +3,7 @@
# @ECLASS: ssl-cert.eclass
# @MAINTAINER:
+# maintainer-needed@gentoo.org
# @AUTHOR:
# Max Kalika <max@gentoo.org>
# @SUPPORTED_EAPIS: 1 2 3 4 5 6 7
diff --git a/eclass/stardict.eclass b/eclass/stardict.eclass
index cbfb10c54552..075c832829bf 100644
--- a/eclass/stardict.eclass
+++ b/eclass/stardict.eclass
@@ -1,11 +1,14 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# Author : Alastair Tse <liquidx@gentoo.org>
-#
-# Convienence class to do stardict dictionary installations.
-#
-# Usage:
+# @ECLASS: stardict.eclass
+# @MAINTAINER:
+# maintainer-needed@gentoo.org
+# @AUTHOR:
+# Alastair Tse <liquidx@gentoo.org>
+# @BLURB: eclass to do stardict dictionary installations.
+
+# @Usage:
# - Variables to set :
# * FROM_LANG - From this language
# * TO_LANG - To this language
diff --git a/eclass/toolchain.eclass b/eclass/toolchain.eclass
index 59f8660a3d90..91797cab67d2 100644
--- a/eclass/toolchain.eclass
+++ b/eclass/toolchain.eclass
@@ -1,8 +1,14 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# Maintainer: Toolchain Ninjas <toolchain@gentoo.org>
+# @ECLASS: toolchain.eclass
+# @MAINTAINER:
+# Toolchain Ninjas <toolchain@gentoo.org>
+# @MAINTAINER:
+# Toolchain Ninjas <toolchain@gentoo.org>
# @SUPPORTED_EAPIS: 5 6 7
+# @BLURB: Basic toolchain stuff
+
DESCRIPTION="The GNU Compiler Collection"
HOMEPAGE="https://gcc.gnu.org/"
diff --git a/eclass/vim-doc.eclass b/eclass/vim-doc.eclass
index 5f281eba25f2..e21e2611296c 100644
--- a/eclass/vim-doc.eclass
+++ b/eclass/vim-doc.eclass
@@ -1,6 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-#
+
+# @ECLASS: vim-doc.eclass
+# @MAINTAINER:
+# Vim project <vim@gentoo.org>
+# @BLURB: Work with Vim documentation
+# @DESCRIPTION:
# This eclass is used by vim.eclass and vim-plugin.eclass to update
# the documentation tags. This is necessary since vim doesn't look in
# /usr/share/vim/vimfiles/doc for documentation; it only uses the
diff --git a/gui-libs/wayfire-plugins-extra/Manifest b/gui-libs/wayfire-plugins-extra/Manifest
new file mode 100644
index 000000000000..ae71f9dcce9c
--- /dev/null
+++ b/gui-libs/wayfire-plugins-extra/Manifest
@@ -0,0 +1 @@
+DIST wayfire-plugins-extra-0.6.0.tar.gz 47411 BLAKE2B 32f784abff6b0f05cdfde0bd491e6c8321eb6038f5ac49ff5b241e628abfb0002289fac6f1deaef4148fd8e071ad08c54ea15a441f9d6356ca43bbf4beb9c7b6 SHA512 2ad35cc54892cf716e8492227f96cab7eb89173294ef928115ca998c8c06e9daef69f60d6d11c5393a3038ded0184ccaa404552fe6035a019682d2fdbe4b768d
diff --git a/gui-libs/wayfire-plugins-extra/metadata.xml b/gui-libs/wayfire-plugins-extra/metadata.xml
new file mode 100644
index 000000000000..cfbacced2332
--- /dev/null
+++ b/gui-libs/wayfire-plugins-extra/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-0.6.0.ebuild b/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-0.6.0.ebuild
new file mode 100644
index 000000000000..74ef87cc7523
--- /dev/null
+++ b/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-0.6.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="extra plugins for wayfire"
+HOMEPAGE="https://github.com/WayfireWM/wayfire-plugins-extra"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/wayfire-plugins-extra.git"
+else
+ SRC_URI="https://github.com/WayfireWM/wayfire-plugins-extra/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="
+ dev-cpp/glibmm
+ >=gui-libs/wlroots-0.11.0
+ >=gui-wm/wayfire-${PV%.*}
+ x11-libs/cairo
+"
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+"
diff --git a/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-9999.ebuild b/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-9999.ebuild
new file mode 100644
index 000000000000..74ef87cc7523
--- /dev/null
+++ b/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="extra plugins for wayfire"
+HOMEPAGE="https://github.com/WayfireWM/wayfire-plugins-extra"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/wayfire-plugins-extra.git"
+else
+ SRC_URI="https://github.com/WayfireWM/wayfire-plugins-extra/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="
+ dev-cpp/glibmm
+ >=gui-libs/wlroots-0.11.0
+ >=gui-wm/wayfire-${PV%.*}
+ x11-libs/cairo
+"
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+"
diff --git a/gui-wm/hikari/hikari-2.2.2.ebuild b/gui-wm/hikari/hikari-2.2.2-r1.ebuild
index 2d87cfd595d1..a9bbaec4c529 100644
--- a/gui-wm/hikari/hikari-2.2.2.ebuild
+++ b/gui-wm/hikari/hikari-2.2.2-r1.ebuild
@@ -45,7 +45,6 @@ pkg_setup() {
}
src_compile() {
-
${MAKE} -j$(makeopts_jobs) VERSION="{PV}" \
CC="$(tc-getCC)" \
CFLAGS_EXTRA="${CFLAGS}" \
@@ -54,13 +53,14 @@ src_compile() {
$(usex gamma -DWITH_GAMMACONTROL "") \
$(usex layershell -DWITH_LAYERSHELL "") \
$(usex screencopy -DWITH_SCREENCOPY "") \
- $(usex suid -DWITH_SUID "") \
$(usex virtual-io -DWITH_VIRTUAL_INPUT "") \
$(usex X -DWITH_XWAYLAND "") \
all || die
}
src_install() {
- ${MAKE} DESTDIR="${D}" PREFIX=/usr ETC_PREFIX=/ install || die
+ ${MAKE} DESTDIR="${D}" PREFIX=/usr ETC_PREFIX=/ \
+ $(usex suid "" -DWITHOUT_SUID) \
+ install || die
doman share/man/man1/hikari.1
}