summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail-client/aerc/Manifest2
-rw-r--r--mail-client/aerc/aerc-0.18.1.ebuild74
2 files changed, 0 insertions, 76 deletions
diff --git a/mail-client/aerc/Manifest b/mail-client/aerc/Manifest
index 20f98a634851..9e910592daae 100644
--- a/mail-client/aerc/Manifest
+++ b/mail-client/aerc/Manifest
@@ -1,4 +1,2 @@
-DIST aerc-0.18.1-deps.tar.xz 19518312 BLAKE2B cf504bc945f2ea20351829f8fea49d0c057e420916b9ed7d73ce8bc60be7f4a64bb73655470caa66a7b8cc25f204236c775934bc52e417716f8538786e1f473c SHA512 8b8c487b73c96036e61648007b06e67af6c6b608810c36e0f92dc64bec7228a1a9782ab452de3ba1063ce693558a554d683cb2fc5f41e84700b9f31e8ff51f55
-DIST aerc-0.18.1.tar.gz 447293 BLAKE2B 4284611f510c47003f895e82bea5bcb6959b08de47cfd88c5dcda455190b94d5855a2f1a514f99b4120a25ffd2b53323de9dd5f960f81214edfc1fb6eafeb2f9 SHA512 38429da656e82cbf63ebfcce655644d4bb7b390c22a2bf93e0bd77448f20a5513aa7dad687e9188ebc222edecc488cee025362e5fa3abd484d1b574261c93c98
DIST aerc-0.18.2-deps.tar.xz 19518064 BLAKE2B efc0b54852e96f1a4eaa3c6d0846df022f36670167d1b0042ae443a1216a8b42ae11624eabbac56956c5fa164fe4494942dd9dbabd37d8b4fde1823162b0ea34 SHA512 f2b3204912c7a81fe5e533fe22e293c59f28192cf05f517a4205b0e92337994157f7f9f031fc33c5a8ace67003afc44606b6faca0c9c26b13d9639934ab39ee3
DIST aerc-0.18.2.tar.gz 447348 BLAKE2B e5979dfe6a0d5c9335eae758c085dc0fd9d45298a537a41e6e3999407395e3ad936e9917c2140d47fcd295cbfc4e8233c4621830b399d70fab0a0c3fa8878315 SHA512 accce8bf2d5e90bffa615e58c68cb187e2eb0ede64bbebe69735c1367c51f286d2dfa505f6b0c67a5958f32afacb9903b1c12e397e64e49403807b78d3bad25c
diff --git a/mail-client/aerc/aerc-0.18.1.ebuild b/mail-client/aerc/aerc-0.18.1.ebuild
deleted file mode 100644
index 51bfaed44158..000000000000
--- a/mail-client/aerc/aerc-0.18.1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 2019-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit go-module xdg
-
-DESCRIPTION="Email client for your terminal"
-HOMEPAGE="https://aerc-mail.org"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://git.sr.ht/~rjarry/aerc"
-else
- SRC_URI="https://git.sr.ht/~rjarry/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
- KEYWORDS="~amd64 ~ppc64"
-fi
-
-LICENSE="Apache-2.0 BSD BSD-2 MIT"
-SLOT="0"
-IUSE="notmuch"
-
-DEPEND="notmuch? ( net-mail/notmuch:= )"
-RDEPEND="${DEPEND}"
-BDEPEND="
- >=app-text/scdoc-1.11.3
- >=dev-lang/go-1.18
-"
-
-src_unpack() {
- if [[ ${PV} == *9999 ]]; then
- git-r3_src_unpack
- go-module_live_vendor
- else
- go-module_src_unpack
- fi
-}
-
-src_compile() {
- unset LDFLAGS
- emake GOFLAGS="$(usex notmuch "-tags=notmuch" "")" \
- PREFIX="${EPREFIX}/usr" VERSION=${PV} all
-}
-
-src_install() {
- emake GOFLAGS="$(usex notmuch "-tags=notmuch" "")" \
- DESTDIR="${ED}" PREFIX="${EPREFIX}/usr" VERSION="${PV}" install
- einstalldocs
- dodoc CHANGELOG.md
-}
-
-src_test() {
- emake tests
-}
-
-pkg_postinst() {
- if [[ -z ${REPLACING_VERSIONS} ]]; then
- elog "If you want to allow your users to activate html email"
- elog "processing via w3m as shown in the tutorial, make sure you"
- elog "emerge net-proxy/dante and www-client/w3m"
- fi
-
- local v
- for v in ${REPLACING_VERSIONS}; do
- if ver_test $v -lt 0.3.0-r1; then
- elog "The dependencies on net-proxy/dante and www-client/w3m"
- elog "have been removed since they are optional."
- elog "Please emerge them before the next --depclean if you"
- elog "need to use them."
- fi
- done
- xdg_pkg_postinst
-}