summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-crypt/gnupg/gnupg-2.2.41.ebuild10
-rw-r--r--app-crypt/gnupg/gnupg-2.4.0.ebuild8
-rw-r--r--dev-libs/zziplib/zziplib-0.13.72-r1.ebuild45
-rw-r--r--dev-libs/zziplib/zziplib-0.13.72.ebuild45
-rw-r--r--kde-apps/libkdcraw/files/libkdcraw-22.12.0-libraw-0.21.patch28
-rw-r--r--kde-apps/libkdcraw/libkdcraw-22.12.0.ebuild2
-rw-r--r--media-gfx/krita/files/krita-5.1.4-libraw-0.21.patch28
-rw-r--r--media-gfx/krita/krita-5.1.4-r1.ebuild5
-rw-r--r--net-libs/libupnp/libupnp-1.14.15.ebuild2
-rw-r--r--net-nds/yp-tools/yp-tools-4.2.3-r1.ebuild3
-rw-r--r--profiles/base/package.use.mask4
-rw-r--r--profiles/package.mask17
-rw-r--r--sys-apps/net-tools/net-tools-2.10.ebuild3
-rw-r--r--sys-apps/net-tools/net-tools-9999.ebuild5
-rw-r--r--x11-base/xwayland/Manifest1
-rw-r--r--x11-base/xwayland/xwayland-22.1.7.ebuild100
-rw-r--r--x11-misc/xsnow/Manifest1
-rw-r--r--x11-misc/xsnow/metadata.xml3
-rw-r--r--x11-misc/xsnow/xsnow-3.5.3-r1.ebuild (renamed from x11-misc/xsnow/xsnow-3.5.3.ebuild)1
-rw-r--r--x11-misc/xsnow/xsnow-3.6.0.ebuild40
20 files changed, 245 insertions, 106 deletions
diff --git a/app-crypt/gnupg/gnupg-2.2.41.ebuild b/app-crypt/gnupg/gnupg-2.2.41.ebuild
index ab8c34f65904..37e68bc395e3 100644
--- a/app-crypt/gnupg/gnupg-2.2.41.ebuild
+++ b/app-crypt/gnupg/gnupg-2.2.41.ebuild
@@ -150,11 +150,9 @@ my_src_test() {
my_src_install() {
emake DESTDIR="${D}" install
- use tools &&
- dobin \
- tools/{convert-from-106,gpg-check-pattern} \
- tools/{gpg-zip,gpgconf,gpgsplit,lspgpot,mail-signed-keys} \
- tools/make-dns-cert
+ use tools && dobin \
+ tools/{gpg-zip,gpgconf,gpgsplit,gpg-check-pattern} \
+ tools/make-dns-cert
dosym gpg /usr/bin/gpg2
dosym gpgv /usr/bin/gpgv2
@@ -170,6 +168,8 @@ my_src_install() {
my_src_install_all() {
einstalldocs
+ use tools && dobin tools/{convert-from-106,mail-signed-keys,lspgpot}
+
use doc && dodoc doc/*.png
systemd_douserunit doc/examples/systemd-user/*.{service,socket}
diff --git a/app-crypt/gnupg/gnupg-2.4.0.ebuild b/app-crypt/gnupg/gnupg-2.4.0.ebuild
index cd23acb62742..8c58fb2730da 100644
--- a/app-crypt/gnupg/gnupg-2.4.0.ebuild
+++ b/app-crypt/gnupg/gnupg-2.4.0.ebuild
@@ -154,11 +154,7 @@ my_src_test() {
my_src_install() {
emake DESTDIR="${D}" install
- use tools &&
- dobin \
- tools/{convert-from-106,gpg-check-pattern} \
- tools/{gpgconf,gpgsplit,lspgpot,mail-signed-keys} \
- tools/make-dns-cert
+ use tools && dobin tools/{gpgconf,gpgsplit,gpg-check-pattern} tools/make-dns-cert
dosym gpg /usr/bin/gpg2
dosym gpgv /usr/bin/gpgv2
@@ -174,6 +170,8 @@ my_src_install() {
my_src_install_all() {
einstalldocs
+ use tools && dobin tools/{convert-from-106,mail-signed-keys,lspgpot}
+
use doc && dodoc doc/*.png
systemd_douserunit doc/examples/systemd-user/*.{service,socket}
diff --git a/dev-libs/zziplib/zziplib-0.13.72-r1.ebuild b/dev-libs/zziplib/zziplib-0.13.72-r1.ebuild
deleted file mode 100644
index c8ee6ff4ef33..000000000000
--- a/dev-libs/zziplib/zziplib-0.13.72-r1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit cmake flag-o-matic python-any-r1
-
-DESCRIPTION="Lightweight library for extracting data from files archived in a single zip file"
-HOMEPAGE="https://github.com/gdraheim/zziplib https://zziplib.sourceforge.net"
-SRC_URI="https://github.com/gdraheim/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
-SLOT="0/13"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="sdl static-libs"
-
-# Tests require internet access
-# https://github.com/gdraheim/zziplib/issues/24
-
-BDEPEND="
- ${PYTHON_DEPS}
-"
-DEPEND="
- sys-libs/zlib
- sdl? ( >=media-libs/libsdl-1.2.6 )
-"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- # https://github.com/gdraheim/zziplib/commit/f3bfc0dd6663b7df272cc0cf17f48838ad724a2f#diff-b7b1e314614cf326c6e2b6eba1540682R100
- append-flags -fno-strict-aliasing
-
- local mycmakeargs=(
- -DZZIPSDL="$(usex sdl)"
- -DBUILD_STATIC_LIBS="$(usex static-libs)"
- -DBUILD_TESTS=OFF
- -DZZIPTEST=OFF
- -DZZIPDOCS=ON
- -DZZIPWRAP=OFF
- )
-
- cmake_src_configure
-}
diff --git a/dev-libs/zziplib/zziplib-0.13.72.ebuild b/dev-libs/zziplib/zziplib-0.13.72.ebuild
deleted file mode 100644
index bc39bf3ec8d0..000000000000
--- a/dev-libs/zziplib/zziplib-0.13.72.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit cmake flag-o-matic python-any-r1
-
-DESCRIPTION="Lightweight library for extracting data from files archived in a single zip file"
-HOMEPAGE="https://github.com/gdraheim/zziplib https://zziplib.sourceforge.net"
-SRC_URI="https://github.com/gdraheim/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
-SLOT="0/13"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="sdl static-libs"
-
-# Tests require internet access
-# https://github.com/gdraheim/zziplib/issues/24
-
-BDEPEND="
- ${PYTHON_DEPS}
-"
-DEPEND="
- sys-libs/zlib
- sdl? ( >=media-libs/libsdl-1.2.6 )
-"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- # https://github.com/gdraheim/zziplib/commit/f3bfc0dd6663b7df272cc0cf17f48838ad724a2f#diff-b7b1e314614cf326c6e2b6eba1540682R100
- append-flags -fno-strict-aliasing
-
- local mycmakeargs=(
- -DZZIPSDL="$(usex sdl)"
- -DBUILD_STATIC_LIBS="$(usex static-libs)"
- -DBUILD_TESTS=OFF
- -DZZIPTEST=OFF
- -DZZIPDOCS=ON
- -DZZIPWRAP=OFF
- )
-
- cmake_src_configure
-}
diff --git a/kde-apps/libkdcraw/files/libkdcraw-22.12.0-libraw-0.21.patch b/kde-apps/libkdcraw/files/libkdcraw-22.12.0-libraw-0.21.patch
new file mode 100644
index 000000000000..1c03556777f3
--- /dev/null
+++ b/kde-apps/libkdcraw/files/libkdcraw-22.12.0-libraw-0.21.patch
@@ -0,0 +1,28 @@
+From 0843c601cbb9a9bb5774ed01b7d90e68fd17950a Mon Sep 17 00:00:00 2001
+From: Antonio Rojas <arojas@archlinux.org>
+Date: Sun, 18 Dec 2022 15:59:51 +0100
+Subject: [PATCH] Fix build with libraw 0.21
+
+---
+ src/kdcraw.cpp | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/src/kdcraw.cpp b/src/kdcraw.cpp
+index 376a37d..1433c4b 100644
+--- a/src/kdcraw.cpp
++++ b/src/kdcraw.cpp
+@@ -357,7 +357,11 @@ bool KDcraw::extractRAWData(const QString& filePath, QByteArray& rawData, DcrawI
+ d->setProgress(0.3);
+
+ raw.imgdata.params.output_bps = 16;
++#if LIBRAW_COMPILE_CHECK_VERSION_NOTLESS(0, 21)
++ raw.imgdata.rawparams.shot_select = shotSelect;
++#else
+ raw.imgdata.params.shot_select = shotSelect;
++#endif
+ ret = raw.unpack();
+
+ if (ret != LIBRAW_SUCCESS)
+--
+GitLab
+
diff --git a/kde-apps/libkdcraw/libkdcraw-22.12.0.ebuild b/kde-apps/libkdcraw/libkdcraw-22.12.0.ebuild
index 7cee686a58c3..1997ea10e90a 100644
--- a/kde-apps/libkdcraw/libkdcraw-22.12.0.ebuild
+++ b/kde-apps/libkdcraw/libkdcraw-22.12.0.ebuild
@@ -18,3 +18,5 @@ DEPEND="
>=media-libs/libraw-0.16:=
"
RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-libraw-0.21.patch ) # bug 887355
diff --git a/media-gfx/krita/files/krita-5.1.4-libraw-0.21.patch b/media-gfx/krita/files/krita-5.1.4-libraw-0.21.patch
new file mode 100644
index 000000000000..9cdd0a9f8161
--- /dev/null
+++ b/media-gfx/krita/files/krita-5.1.4-libraw-0.21.patch
@@ -0,0 +1,28 @@
+From e753d2453d1614b65b288e49fa5d5371764feaa8 Mon Sep 17 00:00:00 2001
+From: Antonio Rojas <arojas@archlinux.org>
+Date: Sun, 18 Dec 2022 16:28:38 +0100
+Subject: [PATCH] Fix build with libraw 0.21
+
+---
+ plugins/impex/raw/3rdparty/libkdcraw/src/kdcraw.cpp | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/plugins/impex/raw/3rdparty/libkdcraw/src/kdcraw.cpp b/plugins/impex/raw/3rdparty/libkdcraw/src/kdcraw.cpp
+index dcaecc6fa7..71425f909c 100644
+--- a/plugins/impex/raw/3rdparty/libkdcraw/src/kdcraw.cpp
++++ b/plugins/impex/raw/3rdparty/libkdcraw/src/kdcraw.cpp
+@@ -383,7 +383,11 @@ bool KDcraw::extractRAWData(const QString& filePath, QByteArray& rawData, DcrawI
+ d->setProgress(0.3);
+
+ raw.imgdata.params.output_bps = 16;
++#if LIBRAW_COMPILE_CHECK_VERSION_NOTLESS(0, 21)
++ raw.imgdata.rawparams.shot_select = shotSelect;
++#else
+ raw.imgdata.params.shot_select = shotSelect;
++#endif
+ ret = raw.unpack();
+
+ if (ret != LIBRAW_SUCCESS)
+--
+GitLab
+
diff --git a/media-gfx/krita/krita-5.1.4-r1.ebuild b/media-gfx/krita/krita-5.1.4-r1.ebuild
index abf1cf77bf49..86ce7588ec21 100644
--- a/media-gfx/krita/krita-5.1.4-r1.ebuild
+++ b/media-gfx/krita/krita-5.1.4-r1.ebuild
@@ -85,7 +85,10 @@ BDEPEND="
sys-devel/gettext
"
-PATCHES=( "${FILESDIR}"/${PN}-4.3.1-tests-optional.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.1-tests-optional.patch
+ "${FILESDIR}"/${P}-libraw-0.21.patch # bug 887473
+)
pkg_setup() {
python-single-r1_pkg_setup
diff --git a/net-libs/libupnp/libupnp-1.14.15.ebuild b/net-libs/libupnp/libupnp-1.14.15.ebuild
index 114444fd8d8e..24f5f843803a 100644
--- a/net-libs/libupnp/libupnp-1.14.15.ebuild
+++ b/net-libs/libupnp/libupnp-1.14.15.ebuild
@@ -14,7 +14,7 @@ S="${WORKDIR}/${MY_PN}-release-${PV}"
LICENSE="BSD"
SLOT="0/17"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ppc ppc64 ~riscv sparc x86 ~amd64-linux"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ppc ppc64 ~riscv sparc x86 ~amd64-linux"
IUSE="blocking-tcp debug doc +reuseaddr samples +ssl static-libs"
RDEPEND="ssl? ( dev-libs/openssl:0= )"
diff --git a/net-nds/yp-tools/yp-tools-4.2.3-r1.ebuild b/net-nds/yp-tools/yp-tools-4.2.3-r1.ebuild
index ad99f5637bd4..b3b55f59117f 100644
--- a/net-nds/yp-tools/yp-tools-4.2.3-r1.ebuild
+++ b/net-nds/yp-tools/yp-tools-4.2.3-r1.ebuild
@@ -20,7 +20,8 @@ DEPEND="
>=net-libs/libnsl-1.2.0:0=
virtual/libcrypt:=
nls? ( virtual/libintl )"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ !sys-apps/net-tools[nis(-)]"
BDEPEND="virtual/pkgconfig
nls? ( sys-devel/gettext )"
diff --git a/profiles/base/package.use.mask b/profiles/base/package.use.mask
index a79caa68e4a6..56637cb12e02 100644
--- a/profiles/base/package.use.mask
+++ b/profiles/base/package.use.mask
@@ -6,6 +6,10 @@
# This file is only for generic masks. For arch-specific masks (i.e.
# mask everywhere, unmask on arch/*) use arch/base.
+# Michał Górny <mgorny@gentoo.org> (2022-12-20)
+# sys-cluster/ganglia is masked for removal.
+app-metrics/collectd collectd_plugins_gmond
+
# Sam James <sam@gentoo.org> (2022-12-17)
# Broken when trying to use sys-libs/binutils-libs header, bug #879067
>=x11-libs/cairo-1.17.6 debug
diff --git a/profiles/package.mask b/profiles/package.mask
index c84a8268bb2a..efed1ef727f1 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -34,6 +34,23 @@
#--- END OF EXAMPLES ---
# Michał Górny <mgorny@gentoo.org> (2022-12-20)
+# Pending version bump since 2015. No new upstream releases since.
+# Removal on 2023-01-19. Bug #887489.
+sys-cluster/ganglia
+
+# Michał Górny <mgorny@gentoo.org> (2022-12-20)
+# Unmaintained. Pending version bump since 2019. Even then, the newest
+# upstream release has known vulnerabilities.
+# Removal on 2023-01-19. Bug #696480.
+sys-cluster/ganglia-web
+
+# Michał Górny <mgorny@gentoo.org> (2022-12-20)
+# Proprietary MPEG library that is no longer fetchable. No reverse
+# dependencies.
+# Removal on 2023-01-19. Bug #759190.
+media-video/mpeg2vidcodec
+
+# Michał Górny <mgorny@gentoo.org> (2022-12-20)
# An unmaintained library that was "quickly whipped up for some demos".
# Last bumped in 2011. No reverse dependencies.
# Removal on 2023-01-19. Bug #847406.
diff --git a/sys-apps/net-tools/net-tools-2.10.ebuild b/sys-apps/net-tools/net-tools-2.10.ebuild
index 71379f1a2ef6..fca68bc4c63d 100644
--- a/sys-apps/net-tools/net-tools-2.10.ebuild
+++ b/sys-apps/net-tools/net-tools-2.10.ebuild
@@ -23,7 +23,8 @@ REQUIRED_USE="nis? ( hostname )"
DEPEND="selinux? ( sys-libs/libselinux )"
RDEPEND="${DEPEND}
- hostname? ( !sys-apps/coreutils[hostname] )"
+ hostname? ( !sys-apps/coreutils[hostname] )
+ nis? ( !net-nds/yp-tools )"
BDEPEND="
selinux? ( virtual/pkgconfig )
app-arch/xz-utils
diff --git a/sys-apps/net-tools/net-tools-9999.ebuild b/sys-apps/net-tools/net-tools-9999.ebuild
index 96f533d8a695..66cdcd23d4c1 100644
--- a/sys-apps/net-tools/net-tools-9999.ebuild
+++ b/sys-apps/net-tools/net-tools-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -23,7 +23,8 @@ REQUIRED_USE="nis? ( hostname )"
DEPEND="selinux? ( sys-libs/libselinux )"
RDEPEND="${DEPEND}
- hostname? ( !sys-apps/coreutils[hostname] )"
+ hostname? ( !sys-apps/coreutils[hostname] )
+ nis? ( !net-nds/yp-tools )"
BDEPEND="
selinux? ( virtual/pkgconfig )
app-arch/xz-utils
diff --git a/x11-base/xwayland/Manifest b/x11-base/xwayland/Manifest
index c2faa8dc576c..83668248e534 100644
--- a/x11-base/xwayland/Manifest
+++ b/x11-base/xwayland/Manifest
@@ -1,2 +1,3 @@
DIST xwayland-22.1.5.tar.xz 1273444 BLAKE2B a6773f2b9655d0651a0a686f5e1fa41bdeaba998dc3e42c2c24dcc262d2affdb055c7ab0cf32b94ba11c82cbfe91bfcf10eb651f678feda95fccb55cc21d2e4f SHA512 806219692be297419777ad5343158f72473a691f7c8be4468fac185a3bc5e3b6811755de3133c12f3694480e51529ac3fa409b22640a80a233925716fec24c06
DIST xwayland-22.1.6.tar.xz 1273532 BLAKE2B aa0604e425c8e5648966f58d8baa56163f7f39b439618e4fe556cdbfd7d417e4d8b1d34a7d850d31ed51b782e268c05f8d8ef4c8c48b3f8c702aabe8e579fb0f SHA512 a78f44f14a6c1e25afbf245c5c757a253f0607afdc80c8b852cf6f810247566d1cc17b63d4442a21d8e69bdb696faf1014438ad98a977fbed9a11b9c5b85e0a4
+DIST xwayland-22.1.7.tar.xz 1273476 BLAKE2B 9e128ff85690c6fb35eb196eefd49b1cf24aed290fd74cdb6e2fb8ad72d61b8dd9dccf83bdafc9a8e1ba13dc61135a7756dbae5ff40490d2076516d72818dbb1 SHA512 dc4187d4e9e1bbf5f431a4a71da01b773be3a8870c3f82da599739d9f72756ac69c1fb8cc3b6c96c88da3c1dd40ce42429a3a003c08f90fc337ebaf6200de649
diff --git a/x11-base/xwayland/xwayland-22.1.7.ebuild b/x11-base/xwayland/xwayland-22.1.7.ebuild
new file mode 100644
index 000000000000..384312c2aa5c
--- /dev/null
+++ b/x11-base/xwayland/xwayland-22.1.7.ebuild
@@ -0,0 +1,100 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/xserver.git"
+ inherit git-r3
+else
+ SRC_URI="https://xorg.freedesktop.org/archive/individual/xserver/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Standalone X server running under Wayland"
+HOMEPAGE="https://wayland.freedesktop.org/xserver.html"
+
+IUSE="selinux video_cards_nvidia unwind xcsecurity"
+
+LICENSE="MIT"
+SLOT="0"
+
+COMMON_DEPEND="
+ dev-libs/libbsd
+ dev-libs/openssl:=
+ >=dev-libs/wayland-1.20
+ >=dev-libs/wayland-protocols-1.22
+ media-fonts/font-util
+ >=media-libs/libepoxy-1.5.4[X,egl(+)]
+ media-libs/libglvnd[X]
+ >=media-libs/mesa-21.1[X(+),egl(+),gbm(+)]
+ >=x11-libs/libdrm-2.4.89
+ >=x11-libs/libXau-1.0.4
+ x11-libs/libxcvt
+ >=x11-libs/libXdmcp-1.0.2
+ >=x11-libs/libXfont2-2.0.1
+ x11-libs/libxkbfile
+ >=x11-libs/libxshmfence-1.1
+ >=x11-libs/pixman-0.27.2
+ >=x11-misc/xkeyboard-config-2.4.1-r3
+
+ unwind? ( sys-libs/libunwind )
+ video_cards_nvidia? ( gui-libs/egl-wayland )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ x11-base/xorg-proto
+ >=x11-libs/xtrans-1.3.5
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ x11-apps/xkbcomp
+ !<=x11-base/xorg-server-1.20.11
+ selinux? ( sec-policy/selinux-xserver )
+"
+BDEPEND="
+ sys-devel/flex
+ dev-util/wayland-scanner
+"
+
+PATCHES=(
+ "${FILESDIR}"/xwayland-drop-redundantly-installed-files.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use selinux xselinux)
+ $(meson_use unwind libunwind)
+ $(meson_use xcsecurity)
+ $(meson_use video_cards_nvidia xwayland_eglstream)
+ -Ddpms=true
+ -Ddri3=true
+ -Ddrm=true
+ -Ddtrace=false
+ -Dglamor=true
+ -Dglx=true
+ -Dipv6=true
+ -Dsecure-rpc=false
+ -Dscreensaver=true
+ -Dsha1=libcrypto
+ -Dxace=true
+ -Dxdmcp=true
+ -Dxinerama=true
+ -Dxvfb=true
+ -Dxv=true
+ -Dxwayland-path="${EPREFIX}"/usr/bin
+ -Ddocs=false
+ -Ddevel-docs=false
+ -Ddocs-pdf=false
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ dosym ../bin/Xwayland /usr/libexec/Xwayland
+
+ meson_src_install
+}
diff --git a/x11-misc/xsnow/Manifest b/x11-misc/xsnow/Manifest
index 2259f6d239bb..947c76d9d527 100644
--- a/x11-misc/xsnow/Manifest
+++ b/x11-misc/xsnow/Manifest
@@ -1,2 +1,3 @@
DIST xsnow-3.3.0.tar.gz 405967 BLAKE2B d2b6d87b781c894c09157ff2f06389d0b1cf401eff735b812ec324560d295195c5afaa3c9c755f569f10f4ff4cd9738dbcc393044dbdebc13454bfeb8e1a9065 SHA512 b2674039ed26c5788a137cf44396b18f07458e926ea0552034d2c78cefaeaffce35ef42f2da386ee48b8b4d8f98960a4a31edfcf737c6d269485785699f9227a
DIST xsnow-3.5.3.tar.gz 474540 BLAKE2B 8b7e841cb2cefe44787b8457d55cc526114b09d7f1f4c435d89519b49295ac89ca73d15a026e2d7095e0f450775ea59763c7d253026fefcc90241390b5d17142 SHA512 e1172660c4fd344454a7b1619321cfe773d35430311f108c6aa7b04f8da7fe4fdf2886a7cd8b4093ad7d2f6fbb0046a12b29598b6ab46d3ad35f8eadb76ff0a5
+DIST xsnow-3.6.0.tar.gz 495875 BLAKE2B 9ebc87254ce81b7fd051bbc0170faa7198390679a8dbaccdfa3674b1f584ad298fa73506b7eb8ff63fe04f168ebafcd30bc2101510c4e912e029edefe4813c65 SHA512 e2684e6d011a8add8819e16b6b649f8d501525c41a4baa0ef32d90b7603e30910a77093c2d21f52a7adb72f0ba18076f9265557e70dc246b365e0fd2b8ed4ab1
diff --git a/x11-misc/xsnow/metadata.xml b/x11-misc/xsnow/metadata.xml
index 96729a07e765..bf0492280805 100644
--- a/x11-misc/xsnow/metadata.xml
+++ b/x11-misc/xsnow/metadata.xml
@@ -4,4 +4,7 @@
<maintainer type="person">
<email>dilfridge@gentoo.org</email>
</maintainer>
+ <upstream>
+ <remote-id type='sourceforge'>xsnow</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/x11-misc/xsnow/xsnow-3.5.3.ebuild b/x11-misc/xsnow/xsnow-3.5.3-r1.ebuild
index e0918534a97e..d57c9e3051f7 100644
--- a/x11-misc/xsnow/xsnow-3.5.3.ebuild
+++ b/x11-misc/xsnow/xsnow-3.5.3-r1.ebuild
@@ -14,6 +14,7 @@ KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~sparc ~x86"
RDEPEND="
dev-libs/glib:2
+ sci-libs/gsl:=
sys-apps/dbus
x11-libs/cairo
x11-libs/gtk+:3
diff --git a/x11-misc/xsnow/xsnow-3.6.0.ebuild b/x11-misc/xsnow/xsnow-3.6.0.ebuild
new file mode 100644
index 000000000000..c8462ed48e95
--- /dev/null
+++ b/x11-misc/xsnow/xsnow-3.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit autotools xdg
+
+DESCRIPTION="let it snow on your desktop and windows"
+HOMEPAGE="https://www.ratrabbit.nl/ratrabbit/xsnow/"
+SRC_URI="https://www.ratrabbit.nl/downloads/xsnow/${P}.tar.gz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ dev-libs/glib:2
+ sci-libs/gsl:=
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXinerama
+ x11-libs/libXpm
+ x11-libs/libXtst
+ x11-libs/libxkbcommon
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.0.7-gamesdir.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}