summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-client/chromium/chromium-113.0.5672.63.ebuild1
-rw-r--r--www-client/chromium/files/chromium-113-gcc-13-0001-vulkanmemoryallocator.patch10
2 files changed, 11 insertions, 0 deletions
diff --git a/www-client/chromium/chromium-113.0.5672.63.ebuild b/www-client/chromium/chromium-113.0.5672.63.ebuild
index 7c514d04f523..cdd81cb02473 100644
--- a/www-client/chromium/chromium-113.0.5672.63.ebuild
+++ b/www-client/chromium/chromium-113.0.5672.63.ebuild
@@ -349,6 +349,7 @@ src_prepare() {
"${FILESDIR}/chromium-113-system-zlib.patch"
"${FILESDIR}/chromium-113-web_view_impl-cstring.patch"
"${FILESDIR}/chromium-113-std-monospace.patch"
+ "${FILESDIR}/chromium-113-gcc-13-0001-vulkanmemoryallocator.patch"
)
if use ppc64 ; then
diff --git a/www-client/chromium/files/chromium-113-gcc-13-0001-vulkanmemoryallocator.patch b/www-client/chromium/files/chromium-113-gcc-13-0001-vulkanmemoryallocator.patch
new file mode 100644
index 000000000000..28372caeb72c
--- /dev/null
+++ b/www-client/chromium/files/chromium-113-gcc-13-0001-vulkanmemoryallocator.patch
@@ -0,0 +1,10 @@
+--- a/third_party/vulkan-deps/vulkan-validation-layers/src/layers/external/vma/vk_mem_alloc.h
++++ b/third_party/vulkan-deps/vulkan-validation-layers/src/layers/external/vma/vk_mem_alloc.h
+@@ -2579,6 +2579,7 @@ VMA_CALL_PRE void VMA_CALL_POST vmaFreeStatsString(
+ #undef VMA_IMPLEMENTATION
+
+ #include <cstdint>
++#include <cstdio>
+ #include <cstdlib>
+ #include <cstring>
+ #include <utility>