summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/unix2tcp/files/unix2tcp-0.8.2-clang16.patch19
-rw-r--r--net-misc/unix2tcp/unix2tcp-0.8.2-r1.ebuild12
2 files changed, 31 insertions, 0 deletions
diff --git a/net-misc/unix2tcp/files/unix2tcp-0.8.2-clang16.patch b/net-misc/unix2tcp/files/unix2tcp-0.8.2-clang16.patch
new file mode 100644
index 000000000000..a67cc13acb26
--- /dev/null
+++ b/net-misc/unix2tcp/files/unix2tcp-0.8.2-clang16.patch
@@ -0,0 +1,19 @@
+https://bugs.gentoo.org/870457
+--- a/server.c
++++ b/server.c
+@@ -61,2 +61,3 @@
+ #include "list.h"
++#include "mylog.h"
+ #include "unix2tcp.h"
+--- a/unix2tcp.c
++++ b/unix2tcp.c
+@@ -62,2 +62,3 @@
+ #include "list.h"
++#include "mylog.h"
+ #include "server.h"
+--- a/utelnet.c
++++ b/utelnet.c
+@@ -23,2 +23,3 @@
+ #include <stdio.h>
++#include <stdlib.h>
+ #ifdef HAVE_SYS_TYPES_H
diff --git a/net-misc/unix2tcp/unix2tcp-0.8.2-r1.ebuild b/net-misc/unix2tcp/unix2tcp-0.8.2-r1.ebuild
index 1fe4b2478e3b..d35532343648 100644
--- a/net-misc/unix2tcp/unix2tcp-0.8.2-r1.ebuild
+++ b/net-misc/unix2tcp/unix2tcp-0.8.2-r1.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit autotools
+
DESCRIPTION="Connection forwarder that converts Unix sockets into TCP sockets"
HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
SRC_URI="mirror://gentoo/${P}.tar.bz2"
@@ -11,4 +13,14 @@ LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 arm ~hppa ~ia64 ppc ~s390 x86"
+PATCHES=(
+ "${FILESDIR}"/${P}-clang16.patch
+)
+
DOCS=( ChangeLog README )
+
+src_prepare() {
+ default
+
+ eautoreconf #870457
+}