summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-frameworks/kio/kio-5.67.0-r1.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/kde-frameworks/kio/kio-5.67.0-r1.ebuild b/kde-frameworks/kio/kio-5.67.0-r1.ebuild
index 3bd5e746e87e..ab22fcb45049 100644
--- a/kde-frameworks/kio/kio-5.67.0-r1.ebuild
+++ b/kde-frameworks/kio/kio-5.67.0-r1.ebuild
@@ -8,7 +8,7 @@ ECM_TEST="forceoptional"
PVCUT=$(ver_cut 1-2)
QTMIN=5.12.3
VIRTUALX_REQUIRED="test"
-inherit ecm kde.org
+inherit ecm kde.org xdg-utils
DESCRIPTION="Framework providing transparent file and data management"
LICENSE="LGPL-2+"
@@ -86,3 +86,13 @@ src_configure() {
ecm_src_configure
}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ ecm_pkg_postrm
+ xdg_desktop_database_update
+}