summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/dictd/dictd-1.12.1-r2.ebuild5
-rw-r--r--app-text/dictd/dictd-1.13.0.ebuild13
-rw-r--r--net-misc/pimpd/pimpd-0.8-r1.ebuild2
-rw-r--r--net-misc/taylor-uucp/files/taylor-uucp-1.07-remove-extern.patch67
-rw-r--r--net-misc/taylor-uucp/taylor-uucp-1.07-r4.ebuild (renamed from net-misc/taylor-uucp/taylor-uucp-1.07-r3.ebuild)38
5 files changed, 101 insertions, 24 deletions
diff --git a/app-text/dictd/dictd-1.12.1-r2.ebuild b/app-text/dictd/dictd-1.12.1-r2.ebuild
index 4da9d8dbf3ae..4feb9c4a5c76 100644
--- a/app-text/dictd/dictd-1.12.1-r2.ebuild
+++ b/app-text/dictd/dictd-1.12.1-r2.ebuild
@@ -13,6 +13,7 @@ SLOT="0"
LICENSE="GPL-2 ISOC-rfc"
KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
IUSE="dbi judy minimal test"
+RESTRICT="!test? ( test )"
# <gawk-3.1.6 makes tests fail.
RDEPEND="
@@ -78,9 +79,9 @@ src_test() {
src_install() {
if use minimal; then
- emake DESTDIR="${D}" install.dictzip install.dict install.dictfmt
+ emake DESTDIR="${ED}" install.dictzip install.dict install.dictfmt
else
- emake DESTDIR="${D}" install
+ emake DESTDIR="${ED}" install
dodoc doc/{dicf.ms,rfc.ms,rfc.sh,rfc2229.txt}
dodoc doc/{security.doc,toc.ms}
diff --git a/app-text/dictd/dictd-1.13.0.ebuild b/app-text/dictd/dictd-1.13.0.ebuild
index 6f994838112e..79c142175876 100644
--- a/app-text/dictd/dictd-1.13.0.ebuild
+++ b/app-text/dictd/dictd-1.13.0.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit readme.gentoo-r1 systemd user
DESCRIPTION="Dictionary Client/Server for the DICT protocol"
@@ -13,6 +14,7 @@ SLOT="0"
LICENSE="GPL-2 ISOC-rfc"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
IUSE="dbi judy minimal test"
+RESTRICT="!test? ( test )"
# <gawk-3.1.6 makes tests fail.
RDEPEND="
@@ -22,9 +24,7 @@ RDEPEND="
dbi? ( dev-db/libdbi )
judy? ( dev-libs/judy )
"
-DEPEND="
- ${RDEPEND}
-"
+DEPEND="${RDEPEND}"
BDEPEND="
>=sys-apps/gawk-3.1.6
virtual/yacc
@@ -39,6 +39,7 @@ DOC_CONTENTS="
\nIf you are running systemd, you will need to review the instructions
explained in /etc/dict/dictd.conf comments.
"
+
PATCHES=(
"${FILESDIR}"/dictd-1.10.11-colorit-nopp-fix.patch
"${FILESDIR}"/dictd-1.12.0-build.patch
@@ -78,15 +79,15 @@ src_test() {
if [[ ${EUID} -eq 0 ]]; then
# If dictd is run as root user (-userpriv) it drops its privileges to
# dictd user and group. Give dictd group write access to test directory.
- chown :dictd "${WORKDIR}" "${S}/test"
- chmod 770 "${WORKDIR}" "${S}/test"
+ chown :dictd "${WORKDIR}" "${S}/test" || die
+ chmod 770 "${WORKDIR}" "${S}/test" || die
fi
emake test
}
src_install() {
if use minimal; then
- emake DESTDIR="${D}" install.dictzip install.dict install.dictfmt
+ emake DESTDIR="${ED}" install.dictzip install.dict install.dictfmt
else
default
diff --git a/net-misc/pimpd/pimpd-0.8-r1.ebuild b/net-misc/pimpd/pimpd-0.8-r1.ebuild
index 446a7aee4235..449da1bcd34c 100644
--- a/net-misc/pimpd/pimpd-0.8-r1.ebuild
+++ b/net-misc/pimpd/pimpd-0.8-r1.ebuild
@@ -11,7 +11,7 @@ SRC_URI="http://cats.meow.at/~peter/pimpd_${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc sparc ~x86"
+KEYWORDS="~amd64 ppc sparc ~x86"
IUSE=""
src_compile() {
diff --git a/net-misc/taylor-uucp/files/taylor-uucp-1.07-remove-extern.patch b/net-misc/taylor-uucp/files/taylor-uucp-1.07-remove-extern.patch
new file mode 100644
index 000000000000..4a8efeeb83f3
--- /dev/null
+++ b/net-misc/taylor-uucp/files/taylor-uucp-1.07-remove-extern.patch
@@ -0,0 +1,67 @@
+From 84b5bf1e6b8cfad657b88f8b061e172e327ef970 Mon Sep 17 00:00:00 2001
+From: Nicolas Boichat <drinkcat@chromium.org>
+Date: Thu, 10 Sep 2020 17:06:37 +0800
+Subject: [PATCH] Remove external function declarations
+
+We need to redeclare functions that we already have.
+
+This causes issues with recent toolchains:
+init.c:100:14: error: redeclaration of 'getcwd' must have the 'overloadable' attribute
+extern char *getcwd ();
+ ^
+/build/amd64-generic/usr/include/bits/unistd.h:158:8: note: previous overload of function is here
+__NTH (getcwd (char *const __clang_pass_object_size __buf, size_t __size))
+ ^
+
+And also reduces the number of build warnings.
+
+This forked repo does the same thing in this (large) cleanup patch:
+https://github.com/quinot/taylor-uucp/commit/b599665ae1e085df0f96de5f50a738fceee02150
+---
+ unix/init.c | 30 ------------------------------
+ 1 file changed, 30 deletions(-)
+
+diff --git a/unix/init.c b/unix/init.c
+index d9d2147edd93..a9b7135be9f4 100644
+--- a/unix/init.c
++++ b/unix/init.c
+@@ -81,36 +81,6 @@
+ #endif /* ! defined (MAXPATHLEN) */
+ #endif /* HAVE_GETWD */
+
+-/* External functions. */
+-#ifndef getlogin
+-extern char *getlogin ();
+-#endif
+-#if GETPWNAM_DECLARATION_OK
+-#ifndef getpwnam
+-extern struct passwd *getpwnam ();
+-#endif
+-#endif
+-#if GETPWUID_DECLARATION_OK
+-#ifndef getpwuid
+-extern struct passwd *getpwuid ();
+-#endif
+-#endif
+-#if HAVE_GETCWD
+-#ifndef getcwd
+-extern char *getcwd ();
+-#endif
+-#endif
+-#if HAVE_GETWD
+-#ifndef getwd
+-extern char *getwd ();
+-#endif
+-#endif
+-#if HAVE_SYSCONF
+-#ifndef sysconf
+-extern long sysconf ();
+-#endif
+-#endif
+-
+ /* Initialize the system dependent routines. We will probably be running
+ suid to uucp, so we make sure that nothing is obviously wrong. We
+ save the login name since we will be losing the real uid. */
+--
+2.28.0.526.ge36021eeef-goog
+
diff --git a/net-misc/taylor-uucp/taylor-uucp-1.07-r3.ebuild b/net-misc/taylor-uucp/taylor-uucp-1.07-r4.ebuild
index c32b453cdeef..40489f01df10 100644
--- a/net-misc/taylor-uucp/taylor-uucp-1.07-r3.ebuild
+++ b/net-misc/taylor-uucp/taylor-uucp-1.07-r4.ebuild
@@ -1,23 +1,28 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
-inherit eutils flag-o-matic autotools
+inherit autotools flag-o-matic
DESCRIPTION="Taylor UUCP"
HOMEPAGE="https://www.airs.com/ian/uucp.html"
SRC_URI="mirror://gnu/uucp/uucp-${PV}.tar.gz"
+S="${WORKDIR}/uucp-${PV}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm ~ia64 ppc sparc x86"
-S="${WORKDIR}/uucp-${PV}"
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-fprintf.patch
+ "${FILESDIR}"/${P}-remove-extern.patch
+)
src_prepare() {
- epatch "${FILESDIR}"/${P}-gentoo.patch
- epatch "${FILESDIR}"/${P}-fprintf.patch
+ default
+
mv configure.{in,ac} || die
sed -i 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die
eautoreconf
@@ -31,7 +36,6 @@ src_configure() {
src_install() {
dodir /usr/share/man/man{1,8}
dodir /usr/share/info
- dodir /etc/uucp
dodir /usr/bin /usr/sbin
diropts -o uucp -g uucp -m 0750
keepdir /var/log/uucp /var/spool/uucp
@@ -39,19 +43,23 @@ src_install() {
keepdir /var/spool/uucppublic
emake \
- "prefix=${D}/usr" \
- "sbindir=${D}/usr/sbin" \
- "bindir=${D}/usr/bin" \
- "man1dir=${D}/usr/share/man/man1" \
- "man8dir=${D}/usr/share/man/man8" \
- "newconfigdir=${D}/etc/uucp" \
- "infodir=${D}/usr/share/info" \
+ "prefix=${ED}/usr" \
+ "sbindir=${ED}/usr/sbin" \
+ "bindir=${ED}/usr/bin" \
+ "man1dir=${ED}/usr/share/man/man1" \
+ "man8dir=${ED}/usr/share/man/man8" \
+ "newconfigdir=${ED}/etc/uucp" \
+ "infodir=${ED}/usr/share/info" \
install install-info
+
sed -i -e 's:/usr/spool:/var/spool:g' sample/config
- cp sample/* "${ED}/etc/uucp" || die
+
+ insinto etc/uucp
+ doins sample/*
+
dodoc ChangeLog NEWS README TODO
}
pkg_preinst() {
- usermod -s /bin/bash uucp
+ usermod -s /bin/bash uucp || die
}