summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/mypy/mypy-1.10.1.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-python/mypy/mypy-1.10.1.ebuild b/dev-python/mypy/mypy-1.10.1.ebuild
index b87fe789fc41..9bd317074557 100644
--- a/dev-python/mypy/mypy-1.10.1.ebuild
+++ b/dev-python/mypy/mypy-1.10.1.ebuild
@@ -63,14 +63,15 @@ PATCHES=(
# test files (https://github.com/mypyc/mypyc/issues/1014)
export CCACHE_DISABLE=1
-src_compile() {
+python_compile() {
local -x MYPY_USE_MYPYC=$(usex native-extensions 1 0)
case ${EPYTHON} in
python3.13)
# https://github.com/mypyc/mypyc/issues/1056
MYPY_USE_MYPYC=0
+ ;;
esac
- distutils-r1_src_compile
+ distutils-r1_python_compile
}
python_test() {