summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/nodejs/nodejs-12.22.5.ebuild8
-rw-r--r--net-libs/nodejs/nodejs-14.17.5.ebuild11
-rw-r--r--net-libs/nodejs/nodejs-16.6.2.ebuild11
-rw-r--r--profiles/package.mask5
4 files changed, 0 insertions, 35 deletions
diff --git a/net-libs/nodejs/nodejs-12.22.5.ebuild b/net-libs/nodejs/nodejs-12.22.5.ebuild
index 19fc9cce0e0d..a8662cb49d0e 100644
--- a/net-libs/nodejs/nodejs-12.22.5.ebuild
+++ b/net-libs/nodejs/nodejs-12.22.5.ebuild
@@ -88,14 +88,6 @@ src_prepare() {
export V=1
export BUILDTYPE=Release
- # There have been cases of other bundled deps bypassing --shared-foo / USE=system-bar,
- # therefore play it safe and make sure dependencies which are not supposed to be bundled
- # aren't there in the first place.
- rm -r deps/{brotli,cares,nghttp2,uv,zlib} || die "Failed to remove undesired bundled deps"
- if use system-ssl; then
- rm -r deps/openssl || die "Failed to remoce bundled OpenSSL"
- fi
-
# fix compilation on Darwin
# https://code.google.com/p/gyp/issues/detail?id=260
sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
diff --git a/net-libs/nodejs/nodejs-14.17.5.ebuild b/net-libs/nodejs/nodejs-14.17.5.ebuild
index 14e49bf0eb0d..d819d8b826f4 100644
--- a/net-libs/nodejs/nodejs-14.17.5.ebuild
+++ b/net-libs/nodejs/nodejs-14.17.5.ebuild
@@ -81,17 +81,6 @@ src_prepare() {
export V=1
export BUILDTYPE=Release
- # There have been cases of other bundled deps bypassing --shared-foo / USE=system-bar,
- # therefore play it safe and make sure dependencies which are not supposed to be bundled
- # aren't there in the first place.
- rm -r deps/{brotli,cares,nghttp2,uv,zlib} || die "Failed to remove undesired bundled deps"
- if use system-icu; then
- rm -r deps/icu-small || die "Failed to remove bundled ICU"
- fi
- if use system-ssl; then
- rm -r deps/openssl || die "Failed to remoce bundled OpenSSL"
- fi
-
# fix compilation on Darwin
# https://code.google.com/p/gyp/issues/detail?id=260
sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
diff --git a/net-libs/nodejs/nodejs-16.6.2.ebuild b/net-libs/nodejs/nodejs-16.6.2.ebuild
index df3eeec96e62..44eb7d90f0a5 100644
--- a/net-libs/nodejs/nodejs-16.6.2.ebuild
+++ b/net-libs/nodejs/nodejs-16.6.2.ebuild
@@ -73,17 +73,6 @@ src_prepare() {
export V=1
export BUILDTYPE=Release
- # There have been cases of other bundled deps bypassing --shared-foo / USE=system-bar,
- # therefore play it safe and make sure dependencies which are not supposed to be bundled
- # aren't there in the first place.
- rm -r deps/{brotli,cares,nghttp2,uv,zlib} || die "Failed to remove undesired bundled deps"
- if use system-icu; then
- rm -r deps/icu-small || die "Failed to remove bundled ICU"
- fi
- if use system-ssl; then
- rm -r deps/openssl || die "Failed to remoce bundled OpenSSL"
- fi
-
# fix compilation on Darwin
# https://code.google.com/p/gyp/issues/detail?id=260
sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
diff --git a/profiles/package.mask b/profiles/package.mask
index 33540076bcbb..692ee5b10e38 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -32,11 +32,6 @@
#--- END OF EXAMPLES ---
-# Sam James <sam@gentoo.org> (2021-08-13)
-# Fails to build with make error in src_install phase.
-# See bug #808063.
-=net-libs/nodejs-16.6.2
-
# David Seifert <soap@gentoo.org> (2021-08-13)
# Dead upstream, new "forked" upstream that just added the last version
# on Github but doesn't maintain them. Unmaintained for the past 10