summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-mobilephone/qtadb/Manifest1
-rw-r--r--app-mobilephone/qtadb/files/qtadb-0.8.1-qt5-5.11.patch14
-rw-r--r--app-mobilephone/qtadb/files/qtadb-0.8.1-qt5.patch100
-rw-r--r--app-mobilephone/qtadb/qtadb-0.8.1-r1.ebuild66
-rw-r--r--dev-db/mariadb/mariadb-10.0.34.ebuild2
-rw-r--r--dev-db/mariadb/mariadb-10.1.31-r1.ebuild2
-rw-r--r--dev-db/unixODBC/unixODBC-2.3.5-r1.ebuild2
-rw-r--r--eclass/vcs-snapshot.eclass3
-rw-r--r--mail-filter/spamassassin/files/spamassassin-3.4.1-bug_7208.patch31
-rw-r--r--mail-filter/spamassassin/spamassassin-3.4.1-r21.ebuild252
-rw-r--r--net-misc/curl/curl-7.59.0.ebuild2
-rw-r--r--sys-apps/hwids/hwids-20171003.ebuild2
-rw-r--r--www-servers/varnish/Manifest1
-rw-r--r--www-servers/varnish/varnish-6.0.0.ebuild102
14 files changed, 574 insertions, 6 deletions
diff --git a/app-mobilephone/qtadb/Manifest b/app-mobilephone/qtadb/Manifest
index 43718c9c9c97..967eb7fa2ca2 100644
--- a/app-mobilephone/qtadb/Manifest
+++ b/app-mobilephone/qtadb/Manifest
@@ -1 +1,2 @@
DIST QtADB_0.8.1_src.zip 1084159 BLAKE2B 8d97024fcccc909d6958168933e5f832fb8ce14aa0ed95b20a2e3c6bb44f9f36451f3c6271991c1a791be56dc5352267d3ffcde60c36795963a4a3e5eac9bc6c SHA512 4bcf28a9442873c3d94c33f5b629c1528efb10a34a6825eb8e596ea6fbb23144a56b64bccc258eaf579ca7d86bd7520f6274d611243290ae6f3bee72021346fa
+DIST qtadb-0.8.1.zip 1104845 BLAKE2B f6f7c08b07c2e59d79e9807850f3ccdedbbc1aff2b94556de748aadc7c26ff8f8bc41275e44e4b4f8249bc1806803c5fea27426d5f895959d546610c0ae07245 SHA512 b407198edd6267ef70e5e2e3b8a094c7b9d9a0bc49dce7e60787e76a1da6e752dd92d7ddbf62a133c44b79118365820b0e710c862c15c9b79f2d7ddf3bc13fd7
diff --git a/app-mobilephone/qtadb/files/qtadb-0.8.1-qt5-5.11.patch b/app-mobilephone/qtadb/files/qtadb-0.8.1-qt5-5.11.patch
new file mode 100644
index 000000000000..49cd49384810
--- /dev/null
+++ b/app-mobilephone/qtadb/files/qtadb-0.8.1-qt5-5.11.patch
@@ -0,0 +1,14 @@
+--- a/widgets/filewidget.cpp 2014-11-22 12:44:42.000000000 +0100
++++ b/widgets/filewidget.cpp 2018-03-17 22:52:25.103930971 +0100
+@@ -21,9 +21,10 @@
+ #include "filewidget.h"
+ #include "ui_filewidget.h"
+
+-#include <QStandardPaths>
++#include <QHeaderView>
+ #include <QMenu>
+ #include <QScrollBar>
++#include <QStandardPaths>
+
+ quint32 qbytearrayToInt32(QByteArray array)
+ {
diff --git a/app-mobilephone/qtadb/files/qtadb-0.8.1-qt5.patch b/app-mobilephone/qtadb/files/qtadb-0.8.1-qt5.patch
new file mode 100644
index 000000000000..a9d182a0b6d2
--- /dev/null
+++ b/app-mobilephone/qtadb/files/qtadb-0.8.1-qt5.patch
@@ -0,0 +1,100 @@
+--- a/QtADB.pro 2018-03-17 12:44:50.933918102 -0400
++++ b/QtADB.pro 2018-03-17 12:46:04.896502772 -0400
+@@ -14,11 +14,13 @@
+ # limitations under the License.
+ #
+ # @author Jakub Motyczko
+ # -------------------------------------------------
+ QT += network
+-QT += declarative
++QT += widgets
++QT += qml
++QT += quick
+ TARGET = QtADB
+
+ TEMPLATE = app
+ SOURCES += main.cpp \
+ ./dialogs/mainwindow.cpp \
+--- a/widgets/messagewidget.h 2018-03-17 12:48:28.691864775 -0400
++++ b/widgets/messagewidget.h 2018-03-17 12:49:55.190870634 -0400
+@@ -21,12 +21,13 @@
+ #ifndef MESSAGEWIDGET_H
+ #define MESSAGEWIDGET_H
+
+ #include <QtGui>
+ #include <QtNetwork>
++#include <QtWidgets>
++#include <QQmlContext>
++#include <QQuickView>
+-#include <QDeclarativeView>
+-#include <QDeclarativeContext>
+
+ #include "../classes/models/messagethreadmodel.h"
+ #include "../classes/models/contactmodel.h"
+
+
+@@ -46,12 +49,12 @@
+ protected:
+ void changeEvent(QEvent *e);
+
+ private:
+ Ui::MessageWidget *ui;
+- QDeclarativeView *qmlView;
+- QDeclarativeContext *qmlViewCtx;
++ QQuickView *qmlView;
++ QQmlContext *qmlViewCtx;
+
+ MessageModel messageModel;
+ MessageThreadModel messageThreadModel;
+ ContactModel contactModel;
+ QSortFilterProxyModel sortModel;
+--- a/widgets/appwidget.h 2018-03-17 12:58:56.731870593 -0400
++++ b/widgets/appwidget.h 2018-03-17 13:03:39.366822784 -0400
+@@ -20,10 +20,11 @@
+
+ #ifndef APPWIDGET_H
+ #define APPWIDGET_H
+
+ #include <QtGui>
++#include <QtWidgets>
+
+ #include "../classes/phone.h"
+ #include "../classes/computer.h"
+ #include "../dialogs/appinfo.h"
+ #include "../dialogs/appdialog.h"
+--- a/widgets/messagewidget.cpp 2018-03-17 16:34:54.003310530 -0400
++++ b/widgets/messagewidget.cpp 2018-03-17 16:34:14.545124690 -0400
+@@ -51,11 +51,11 @@
+ this->sortContactModel.setSortRole(ContactModel::NameRole);
+ this->sortContactModel.sort(0, Qt::AscendingOrder);
+
+ this->messageCount=0;
+
+- this->qmlView = new QDeclarativeView;
++ this->qmlView = new QQuickView;
+ this->qmlViewCtx = this->qmlView->rootContext();
+ if (QFile::exists("qml/messageView.qml"))
+ this->qmlView->setSource(QUrl::fromLocalFile("qml/messageView.qml"));
+ else
+ //this->qmlView->setSource(QUrl::fromLocalFile("../messages/qml/messageView.qml"));
+@@ -63,15 +63,17 @@
+ this->qmlViewCtx->setContextProperty("threadModel", &sortThreadModel);
+ this->qmlViewCtx->setContextProperty("contactModel", &sortContactModel);
+ this->qmlViewCtx->setContextProperty("messageModel", &sortModel);
+ this->qmlViewCtx->setContextProperty("myNickname", "Me");
+ this->qmlViewCtx->setContextProperty("contactDefault", "qrc:/icons/contactDefault.png");
+- qmlView->setResizeMode(QDeclarativeView::SizeRootObjectToView);
+-
++ qmlView->setResizeMode(QQuickView::SizeRootObjectToView);
++
+ this->qmlViewCtx->setContextProperty("messageWidget", this);
++ QWidget *container = QWidget::createWindowContainer(qmlView, this);
++ container->setFocusPolicy(Qt::TabFocus);
+
+- ui->layoutMessages->addWidget(this->qmlView,1,1);
++ ui->layoutMessages->addWidget(container);
+
+ //QSettings settings;
+ //this->sdk = settings.value("sdkPath").toString();
+ this->tcpServer.listen(QHostAddress::Any,4445);
+
diff --git a/app-mobilephone/qtadb/qtadb-0.8.1-r1.ebuild b/app-mobilephone/qtadb/qtadb-0.8.1-r1.ebuild
new file mode 100644
index 000000000000..1c1f06337939
--- /dev/null
+++ b/app-mobilephone/qtadb/qtadb-0.8.1-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+COMMIT=ccbb0c86c9eb
+inherit desktop qmake-utils readme.gentoo-r1
+
+DESCRIPTION="Android phone manager via ADB"
+HOMEPAGE="https://qtadb.wordpress.com"
+SRC_URI="https://bitbucket.org/michalmotyczko/${PN}/get/${COMMIT}.zip -> ${P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-qt5.patch
+ "${FILESDIR}"/${P}-qt5-5.11.patch
+)
+
+S="${WORKDIR}/michalmotyczko-${PN}-${COMMIT}"
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ newicon images/android.png ${PN}.png
+ make_desktop_entry QtADB QtADB ${PN} \
+ "Qt;PDA;Utility;" || ewarn "Desktop entry creation failed"
+ dobin QtADB
+
+ local DOC_CONTENTS="
+You will need a working Android SDK installation (adb and aapt executables)
+You can install Android SDK a) through portage (emerge android-sdk-update-manager
+and run android to download the actual sdk), b) manually from
+http://developer.android.com/sdk/index.html or c) just grab the adb, aapt linux
+binaries from http://qtadb.wordpress.com/download/
+adb and aapt executables are in the platform-tools subdir of Android SDK. You
+must run QtADB from this directory as a user able to write a log file in this
+directory.
+
+Also you will need to have ROOT access to your phone along with busybox
+The latter can be found in the Android market
+
+Last, if you want to use the SMS manager of QtADB, you have to install
+QtADB.apk to your device, available here: http://qtadb.wordpress.com/download/
+
+If you have trouble getting your phone connected through usb (driver problem),
+try adbWireless from Android market to get connected through WiFi
+"
+ readme.gentoo_create_doc
+}
diff --git a/dev-db/mariadb/mariadb-10.0.34.ebuild b/dev-db/mariadb/mariadb-10.0.34.ebuild
index b16e3301b424..c33e7880c587 100644
--- a/dev-db/mariadb/mariadb-10.0.34.ebuild
+++ b/dev-db/mariadb/mariadb-10.0.34.ebuild
@@ -19,7 +19,7 @@ RESTRICT="!bindist? ( bindist )"
REQUIRED_USE="jdbc? ( extraengine server !static ) server? ( tokudb? ( jemalloc !tcmalloc ) ) static? ( !pam )"
# REMEMBER: also update eclass/mysql*.eclass before committing!
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
MY_PATCH_DIR="${WORKDIR}/mysql-extras-${MY_EXTRAS_VER}"
PATCHES=(
diff --git a/dev-db/mariadb/mariadb-10.1.31-r1.ebuild b/dev-db/mariadb/mariadb-10.1.31-r1.ebuild
index e651cae6f970..79621c39d489 100644
--- a/dev-db/mariadb/mariadb-10.1.31-r1.ebuild
+++ b/dev-db/mariadb/mariadb-10.1.31-r1.ebuild
@@ -21,7 +21,7 @@ RESTRICT="!bindist? ( bindist )"
REQUIRED_USE="jdbc? ( extraengine server !static ) server? ( tokudb? ( jemalloc !tcmalloc ) ) static? ( !pam )"
# REMEMBER: also update eclass/mysql*.eclass before committing!
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
MY_PATCH_DIR="${WORKDIR}/mysql-extras-${MY_EXTRAS_VER}"
diff --git a/dev-db/unixODBC/unixODBC-2.3.5-r1.ebuild b/dev-db/unixODBC/unixODBC-2.3.5-r1.ebuild
index aa2e9ab27bc6..e8c514a225d9 100644
--- a/dev-db/unixODBC/unixODBC-2.3.5-r1.ebuild
+++ b/dev-db/unixODBC/unixODBC-2.3.5-r1.ebuild
@@ -10,7 +10,7 @@ SRC_URI="ftp://ftp.unixodbc.org/pub/${PN}/${P}.tar.gz"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ~mips ~ppc ~ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="+minimal odbcmanual static-libs unicode"
RDEPEND="
diff --git a/eclass/vcs-snapshot.eclass b/eclass/vcs-snapshot.eclass
index 3eff6995fae7..243d4a8a3185 100644
--- a/eclass/vcs-snapshot.eclass
+++ b/eclass/vcs-snapshot.eclass
@@ -67,7 +67,8 @@ vcs-snapshot_src_unpack() {
# XXX: check whether the directory structure inside is
# fine? i.e. if the tarball has actually a parent dir.
mkdir "${destdir}" || die
- tar -C "${destdir}" -x --strip-components 1 \
+ # -o (--no-same-owner) to avoid restoring original owner
+ tar -C "${destdir}" -x -o --strip-components 1 \
-f "${DISTDIR}/${f}" || die
;;
*)
diff --git a/mail-filter/spamassassin/files/spamassassin-3.4.1-bug_7208.patch b/mail-filter/spamassassin/files/spamassassin-3.4.1-bug_7208.patch
new file mode 100644
index 000000000000..da97e3ee56f8
--- /dev/null
+++ b/mail-filter/spamassassin/files/spamassassin-3.4.1-bug_7208.patch
@@ -0,0 +1,31 @@
+https://bz.apache.org/SpamAssassin/show_bug.cgi?id=7208
+https://bugs.gentoo.org/650638
+--- a/lib/Mail/SpamAssassin/Plugin/URILocalBL.pm 2015/06/10 12:15:22 1684652
++++ a/lib/Mail/SpamAssassin/Plugin/URILocalBL.pm 2015/06/10 12:18:50 1684653
+@@ -350,7 +350,7 @@
+ # look for W3 links only
+ next unless (defined $info->{types}->{a});
+
+- while (my($host, $domain) = each $info->{hosts}) {
++ while (my($host, $domain) = each %{$info->{hosts}}) {
+
+ # skip if the domain name was matched
+ if (exists $rule->{exclusions} && exists $rule->{exclusions}->{$domain}) {
+@@ -374,7 +374,7 @@
+ }
+
+ if (exists $rule->{countries}) {
+- dbg("check: uri_local_bl countries %s\n", join(' ', sort keys $rule->{countries}));
++ dbg("check: uri_local_bl countries %s\n", join(' ', sort keys %{$rule->{countries}}));
+
+ my $cc = $self->{geoip}->country_code_by_addr($ip);
+
+@@ -403,7 +403,7 @@
+ }
+
+ if (exists $rule->{isps}) {
+- dbg("check: uri_local_bl isps %s\n", join(' ', map { '"' . $_ . '"'; } sort keys $rule->{isps}));
++ dbg("check: uri_local_bl isps %s\n", join(' ', map { '"' . $_ . '"'; } sort keys %{$rule->{isps}}));
+
+ my $isp = $self->{geoisp}->isp_by_name($ip);
+
diff --git a/mail-filter/spamassassin/spamassassin-3.4.1-r21.ebuild b/mail-filter/spamassassin/spamassassin-3.4.1-r21.ebuild
new file mode 100644
index 000000000000..bb451f05de08
--- /dev/null
+++ b/mail-filter/spamassassin/spamassassin-3.4.1-r21.ebuild
@@ -0,0 +1,252 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit perl-functions systemd toolchain-funcs user
+
+MY_P="Mail-SpamAssassin-${PV//_/-}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="An extensible mail filter which can identify and tag spam"
+HOMEPAGE="https://spamassassin.apache.org/"
+SRC_URI="mirror://apache/spamassassin/source/${MY_P}.tar.bz2"
+
+LICENSE="Apache-2.0 GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="berkdb cron ipv6 ldap libressl mysql postgres qmail sqlite ssl test"
+
+# The Makefile.PL script checks for dependencies, but only fails if a
+# required (i.e. not optional) dependency is missing. We therefore
+# require most of the optional modules only at runtime.
+REQDEPEND="dev-lang/perl:=
+ dev-perl/HTML-Parser
+ dev-perl/Net-DNS
+ dev-perl/NetAddr-IP
+ virtual/perl-Archive-Tar
+ virtual/perl-Digest-SHA
+ virtual/perl-IO-Zlib
+ virtual/perl-Time-HiRes
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl )
+ )"
+
+# SpamAssassin doesn't use libwww-perl except as a fallback for when
+# curl/wget are missing, so we depend on one of those instead. Some
+# mirrors use https, so we need those utilities to support SSL.
+#
+# re2c is needed to compile the rules (sa-compile).
+#
+# We still need the old Digest-SHA1 because razor2 has not been ported
+# to Digest-SHA.
+OPTDEPEND="app-crypt/gnupg
+ dev-perl/Digest-SHA1
+ dev-perl/Encode-Detect
+ dev-perl/Geo-IP
+ dev-perl/HTTP-Date
+ dev-perl/Mail-DKIM
+ dev-perl/Mail-SPF
+ dev-perl/Net-Patricia
+ dev-perl/Net-CIDR-Lite
+ dev-util/re2c
+ || ( net-misc/wget[ssl] net-misc/curl[ssl] )
+ virtual/perl-MIME-Base64
+ virtual/perl-Pod-Parser
+ berkdb? ( virtual/perl-DB_File )
+ ipv6? ( dev-perl/IO-Socket-INET6 )
+ ldap? ( dev-perl/perl-ldap )
+ mysql? (
+ dev-perl/DBI
+ dev-perl/DBD-mysql
+ )
+ postgres? (
+ dev-perl/DBI
+ dev-perl/DBD-Pg
+ )
+ sqlite? (
+ dev-perl/DBI
+ dev-perl/DBD-SQLite
+ )
+ ssl? ( dev-perl/IO-Socket-SSL )"
+
+DEPEND="${REQDEPEND}
+ test? (
+ ${OPTDEPEND}
+ virtual/perl-Test-Harness
+ )"
+RDEPEND="${REQDEPEND} ${OPTDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/spamassassin-3.4.1-bug_7199.patch"
+ "${FILESDIR}/spamassassin-3.4.1-bug_7208.patch"
+ "${FILESDIR}/spamassassin-3.4.1-bug_7223.patch"
+ "${FILESDIR}/spamassassin-3.4.1-bug_7231.patch"
+ "${FILESDIR}/spamassassin-3.4.1-bug_7265.patch"
+ "${FILESDIR}/spamassassin-3.4.1-bug_7231-extra.patch"
+ "${FILESDIR}/spamassassin-3.4.1-bug_7404.patch"
+ "${FILESDIR}/spamassassin-3.4.1-bug_7462.patch"
+ "${FILESDIR}/spamassassin-3.4.1-perl526.patch"
+ "${FILESDIR}/spamassassin-3.4.1-bug_7361.patch"
+)
+
+src_prepare() {
+ default
+
+ # The sa_compile test does some weird stuff like hopping around in
+ # the directory tree and calling "make" to create a dist tarball
+ # from ${S}. It fails, and is more trouble than it's worth...
+ perl_rm_files t/sa_compile.t || die 'failed to remove sa_compile test'
+
+ # The spamc tests (which need the networked spamd daemon) fail for
+ # irrelevant reasons. It's too hard to disable them (unlike the
+ # spamd tests themselves -- see src_test), so use a crude
+ # workaround.
+ perl_rm_files t/spamc_*.t || die 'failed to remove spamc tests'
+}
+
+src_configure() {
+ # This is how and where the perl-module eclass disables the
+ # MakeMaker interactive prompt.
+ export PERL_MM_USE_DEFAULT=1
+
+ # Set SYSCONFDIR explicitly so we can't get bitten by bug 48205 again
+ # (just to be sure, nobody knows how it could happen in the first place).
+ #
+ # We also set the path to the perl executable explictly. This will be
+ # used to create the initial shebang line in the scripts (bug 62276).
+ perl Makefile.PL \
+ PREFIX="${EPREFIX}/usr" \
+ INSTALLDIRS=vendor \
+ SYSCONFDIR="${EPREFIX}/etc" \
+ DATADIR="${EPREFIX}/usr/share/spamassassin" \
+ PERL_BIN="${EPREFIX}/usr/bin/perl" \
+ ENABLE_SSL="$(usex ssl)" \
+ DESTDIR="${D}" \
+ || die 'failed to create a Makefile using Makefile.PL'
+
+ # Now configure spamc.
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" spamc/Makefile
+}
+
+src_compile() {
+ emake
+ use qmail && emake spamc/qmail-spamc
+}
+
+src_install () {
+ emake install
+ einstalldocs
+
+ # Create the stub dir used by sa-update and friends
+ keepdir /var/lib/spamassassin
+
+ # Move spamd to sbin where it belongs.
+ dodir /usr/sbin
+ mv "${ED}"/usr/bin/spamd "${ED}"/usr/sbin/spamd || die "move spamd failed"
+
+ if use qmail; then
+ dobin spamc/qmail-spamc
+ fi
+
+ dosym mail/spamassassin /etc/spamassassin
+
+ # Disable plugin by default
+ sed -i -e 's/^loadplugin/\#loadplugin/g' \
+ "${ED}/etc/mail/spamassassin/init.pre" \
+ || die "failed to disable plugins by default"
+
+ # Add the init and config scripts.
+ newinitd "${FILESDIR}/3.4.1-spamd.init-r3" spamd
+ newconfd "${FILESDIR}/3.4.1-spamd.conf-r1" spamd
+
+ systemd_newunit "${FILESDIR}/${PN}.service-r4" "${PN}.service"
+ systemd_install_serviced "${FILESDIR}/${PN}.service.conf-r2" \
+ "${PN}.service"
+
+ use postgres && dodoc sql/*_pg.sql
+ use mysql && dodoc sql/*_mysql.sql
+
+ dodoc NOTICE TRADEMARK CREDITS UPGRADE USAGE sql/README.bayes \
+ sql/README.awl procmailrc.example sample-nonspam.txt \
+ sample-spam.txt spamd/PROTOCOL spamd/README.vpopmail \
+ spamd-apache2/README.apache
+
+ # Rename some files so that they don't clash with others.
+ newdoc spamd/README README.spamd
+ newdoc sql/README README.sql
+ newdoc ldap/README README.ldap
+
+ if use qmail; then
+ dodoc spamc/README.qmail
+ fi
+
+ insinto /etc/mail/spamassassin/
+ insopts -m0400
+ newins "${FILESDIR}"/secrets.cf secrets.cf.example
+
+ # Create the directory where sa-update stores its GPG key (if you
+ # choose to import one). If this directory does not exist, the
+ # import will fail. This is bug 396307. We expect that the import
+ # will be performed as root, and making the directory accessible
+ # only to root prevents a warning on the command-line.
+ diropts -m0700
+ dodir /etc/mail/spamassassin/sa-update-keys
+
+ if use cron; then
+ # Install the cron job if they want it.
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}/update-spamassassin-rules.cron" \
+ update-spamassassin-rules
+ fi
+
+ # Remove perllocal.pod to avoid file collisions (bug #603338).
+ perl_delete_localpod || die "failed to remove perllocal.pod"
+
+ # The perl-module eclass calls three other functions to clean
+ # up in src_install. The first fixes references to ${D} in the
+ # packlist, and is useful to us, too. The other two functions,
+ # perl_delete_emptybsdir and perl_remove_temppath, don't seem
+ # to be needed: there are no empty directories, *.bs files, or
+ # ${D} paths remaining in our installed image.
+ perl_fix_packlist || die "failed to fix paths in packlist"
+}
+
+src_test() {
+ # Trick the test suite into skipping the spamd tests. Setting
+ # SPAMD_HOST to a non-localhost value causes SKIP_SPAMD_TESTS to be
+ # set in SATest.pm.
+ export SPAMD_HOST=disabled
+ default
+}
+
+pkg_preinst() {
+ # The spamd daemon runs as this user. Use a real home directory so
+ # that it can hold SA configuration.
+ enewuser spamd -1 -1 /home/spamd
+}
+
+pkg_postinst() {
+ elog
+ elog 'No rules are installed by default. You will need to run sa-update'
+ elog 'at least once, and most likely configure SpamAssassin before it'
+ elog 'will work.'
+
+ if ! use cron; then
+ elog
+ elog 'You should consider a cron job for sa-update. One is provided'
+ elog 'for daily updates if you enable the "cron" USE flag.'
+ fi
+ elog
+ elog 'Configuration and update help can be found on the wiki:'
+ elog
+ elog ' https://wiki.gentoo.org/wiki/SpamAssassin'
+ elog
+
+ ewarn 'If this version of SpamAssassin causes permissions issues'
+ ewarn 'with your user configurations or bayes databases, then you'
+ ewarn 'may need to set SPAMD_RUN_AS_ROOT=true in your OpenRC service'
+ ewarn 'configuration file, or remove the --username and --groupname'
+ ewarn 'flags from the SPAMD_OPTS variable in your systemd service'
+ ewarn 'configuration file.'
+}
diff --git a/net-misc/curl/curl-7.59.0.ebuild b/net-misc/curl/curl-7.59.0.ebuild
index b0fde15454a2..cf809041edad 100644
--- a/net-misc/curl/curl-7.59.0.ebuild
+++ b/net-misc/curl/curl-7.59.0.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://curl.haxx.se/download/${P}.tar.bz2"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="adns brotli http2 idn ipv6 kerberos ldap metalink rtmp samba ssh ssl static-libs test threads"
IUSE+=" curl_ssl_axtls curl_ssl_gnutls curl_ssl_libressl curl_ssl_mbedtls curl_ssl_nss +curl_ssl_openssl curl_ssl_winssl"
IUSE+=" elibc_Winnt"
diff --git a/sys-apps/hwids/hwids-20171003.ebuild b/sys-apps/hwids/hwids-20171003.ebuild
index ea2219711fb1..cb20b17a18f9 100644
--- a/sys-apps/hwids/hwids-20171003.ebuild
+++ b/sys-apps/hwids/hwids-20171003.ebuild
@@ -13,7 +13,7 @@ if [[ ${PV} == "99999999" ]]; then
EGIT_REPO_URI="${HOMEPAGE}.git"
else
SRC_URI="${HOMEPAGE}/archive/${P}.tar.gz"
- KEYWORDS="alpha amd64 ~arm arm64 ~hppa ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+ KEYWORDS="alpha amd64 ~arm arm64 ~hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
fi
LICENSE="|| ( GPL-2 BSD ) public-domain"
diff --git a/www-servers/varnish/Manifest b/www-servers/varnish/Manifest
index 4d1a3283eef7..f9c6f64a06bc 100644
--- a/www-servers/varnish/Manifest
+++ b/www-servers/varnish/Manifest
@@ -2,3 +2,4 @@ DIST varnish-4.0.5.tgz 1947888 BLAKE2B d921dc6f2abae7b0bd1816470fd41f8555c02a026
DIST varnish-4.1.8.tgz 2254772 BLAKE2B acadf4079d58bb8f0dc5e24713aba7f2786ca6f06a683465b1564bacd986e209d858f9a3100cfb7586fa5d17f7e5f4d8425ece10c609bb3412d3adafa6ad0d05 SHA512 c642359118d87e8713d2ccf817da317a454a0f9ae6f7a07da1d10b5076aa7e5d7dcc203ef71ae19d56b7592db0c66b4ca96cb43d5fa0e6aa588d1dc8e03e026e
DIST varnish-5.1.3.tgz 2643223 BLAKE2B 85bae87785da1284d7d916b8948a0984eea9cf07e96012255435ba04c28e8078e5dad893946bbc12da6cbe9326699458f0e3af6be55cb5e7bba4e622724ddac2 SHA512 a10c317dc38ddff139ca8153f6388955df449c3abeb4d4f069b632ba2b32064a2827ab05fa8515994b251a68507fc3a7bf4e08eacc991fc03283ab234b9efd0a
DIST varnish-5.2.1.tgz 2827676 BLAKE2B 6f50a55a9b16d137eaec59aea98a0179b808bb67fc3de26c9b0924b9937a3688b7f9db45d2f0a71be2b7c6f77bfd47cd22e7b898348b5236114572b5bb33ff22 SHA512 2e979983c7f2325e289768752cc474dc3032c3420de65ccfd5871098c076aecf18e962b04308ecb1860f542fd6f6418dc79220fdd6cf4a75f7476a733faa589c
+DIST varnish-6.0.0.tgz 3033621 BLAKE2B 8fb3c8bf64527476251500ebf809dcff927c8097811e500172d489dd02828981e92034d8c95b8b6d183381d8f3a0fdba633451e8ab17d40d56f7727376378d68 SHA512 39bae462fe40bda9b7c93114ab8256c838a7d67f1a9f7397c37ad090163a33232676120eb7609d0512684a563d8e02c1c2ff5e1b9da0ddedef2250db51c3cc79
diff --git a/www-servers/varnish/varnish-6.0.0.ebuild b/www-servers/varnish/varnish-6.0.0.ebuild
new file mode 100644
index 000000000000..fd1d1a8b7caf
--- /dev/null
+++ b/www-servers/varnish/varnish-6.0.0.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit user autotools systemd python-r1
+
+DESCRIPTION="Varnish is a state-of-the-art, high-performance HTTP accelerator"
+HOMEPAGE="https://varnish-cache.org/"
+SRC_URI="http://varnish-cache.org/_downloads/${P}.tgz"
+
+LICENSE="BSD-2 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="jemalloc jit static-libs"
+
+CDEPEND="
+ sys-libs/readline:0=
+ dev-libs/libpcre[jit?]
+ jemalloc? ( dev-libs/jemalloc )
+ sys-libs/ncurses:0="
+
+#varnish compiles stuff at run time
+RDEPEND="
+ ${PYTHON_DEPS}
+ ${CDEPEND}
+ sys-devel/gcc"
+
+DEPEND="
+ ${CDEPEND}
+ dev-python/docutils
+ virtual/pkgconfig"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="test" #315725
+
+pkg_setup() {
+ ebegin "Creating varnish user and group"
+ enewgroup varnish
+ enewuser varnish -1 -1 /var/lib/varnish varnish
+ eend $?
+}
+
+src_prepare() {
+ # Remove -Werror bug #528354
+ sed -i -e 's/-Werror\([^=]\)/\1/g' configure.ac
+
+ # Upstream doesn't put varnish.m4 in the m4/ directory
+ # We link because the Makefiles look for the file in
+ # the original location
+ ln -sf ../varnish.m4 m4/varnish.m4
+
+ eapply_user
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable jit pcre-jit ) \
+ $(use_with jemalloc)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ python_replicate_script "${D}/usr/share/varnish/vmodtool.py"
+
+ newinitd "${FILESDIR}"/varnishlog.initd varnishlog
+ newconfd "${FILESDIR}"/varnishlog.confd varnishlog
+
+ newinitd "${FILESDIR}"/varnishncsa.initd varnishncsa
+ newconfd "${FILESDIR}"/varnishncsa.confd varnishncsa
+
+ newinitd "${FILESDIR}"/varnishd.initd-r4 varnishd
+ newconfd "${FILESDIR}"/varnishd.confd-r4 varnishd
+
+ insinto /etc/logrotate.d/
+ newins "${FILESDIR}/varnishd.logrotate-r2" varnishd
+
+ diropts -m750
+
+ keepdir /var/lib/varnish
+ keepdir /var/log/varnish
+
+ systemd_dounit "${FILESDIR}/${PN}d.service"
+
+ insinto /etc/varnish/
+ doins lib/libvmod_std/vmod.vcc
+ doins etc/example.vcl
+
+ dodoc README.rst
+ dodoc doc/changes.rst
+
+ fowners root:varnish /etc/varnish/
+ fowners varnish:varnish /var/lib/varnish/
+ fperms 0750 /var/lib/varnish/ /etc/varnish/
+}