summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/snappy')
-rw-r--r--app-arch/snappy/Manifest2
-rw-r--r--app-arch/snappy/metadata.xml15
-rw-r--r--app-arch/snappy/snappy-1.1.1.ebuild40
-rw-r--r--app-arch/snappy/snappy-1.1.2-r1.ebuild41
-rw-r--r--app-arch/snappy/snappy-1.1.2.ebuild40
5 files changed, 138 insertions, 0 deletions
diff --git a/app-arch/snappy/Manifest b/app-arch/snappy/Manifest
new file mode 100644
index 000000000000..f81a04a6fc79
--- /dev/null
+++ b/app-arch/snappy/Manifest
@@ -0,0 +1,2 @@
+DIST snappy-1.1.1.tar.gz 1777992 SHA256 d79f04a41b0b513a014042a4365ec999a1ad5575e10d5e5578720010cb62fab3 SHA512 36b6a1934579dd82a67bcc46626f8dbe9d24d53fe2ca1eca2982d2091054241c9797ada0d4657c484ebc82e7ec11069fd9cd83aac61f4aa1a530167d899041f3 WHIRLPOOL f95ae11130ddd32123e202d6a179b04a5424593937ada0baee9bd17fbb980a9d2d0242df7eb48d795f5d98879b7b025070008852ad7324bc850c0ab0b245612e
+DIST snappy-1.1.2.tar.gz 1485435 SHA256 f9d8fe1c85494f62dbfa3efe8e73bc23d8dec7a254ff7fe09ec4b0ebfc586af4 SHA512 da0e80528dfc815d765347c60dc5f14bc7fb882cc6894b87d3a43dec1a127cf8bcfe46e6cb93e130790c0ebd67368a1042500d9080f844441803c1b69c3cc07e WHIRLPOOL a9cf520cc578a0a63ebb7fb127428b50d282cdf2448938ad88349f775e21b3dd27f2c6843f86dd749d66e9df5e29094bc5c67032f0219932fec69f882ec91246
diff --git a/app-arch/snappy/metadata.xml b/app-arch/snappy/metadata.xml
new file mode 100644
index 000000000000..c9ad814e5692
--- /dev/null
+++ b/app-arch/snappy/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <longdescription lang="en">Snappy is a compression/decompression library. It does not aim for
+ maximum compression, or compatibility with any other compression
+ library; instead, it aims for very high speeds and reasonable
+ compression.</longdescription>
+ <upstream>
+ <remote-id type="google-code">snappy</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-arch/snappy/snappy-1.1.1.ebuild b/app-arch/snappy/snappy-1.1.1.ebuild
new file mode 100644
index 000000000000..4da8c027bd50
--- /dev/null
+++ b/app-arch/snappy/snappy-1.1.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils autotools
+
+DESCRIPTION="A high-speed compression/decompression library by Google"
+HOMEPAGE="https://code.google.com/p/snappy/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+DOCS="AUTHORS ChangeLog README NEWS format_description.txt"
+
+src_prepare() {
+ # Avoid automagic lzop and gzip by not checking for it
+ sed -i -e '/^CHECK_EXT_COMPRESSION_LIB/d' "${S}/configure.ac" || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --without-gflags \
+ --disable-gtest \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ # Remove docs installed by snappy itself
+ rm -rf "${ED}/usr/share/doc/snappy" || die
+
+ prune_libtool_files
+}
diff --git a/app-arch/snappy/snappy-1.1.2-r1.ebuild b/app-arch/snappy/snappy-1.1.2-r1.ebuild
new file mode 100644
index 000000000000..afb12bbf10e5
--- /dev/null
+++ b/app-arch/snappy/snappy-1.1.2-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+AUTOTOOLS_AUTO_DEPEND="yes"
+inherit eutils autotools-multilib
+
+DESCRIPTION="A high-speed compression/decompression library by Google"
+HOMEPAGE="https://code.google.com/p/snappy/"
+# upstream uses google drive which has hash-based URLS
+SRC_URI="http://dev.gentoo.org/~radhermit/dist/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm ~arm64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+src_prepare() {
+ # Avoid automagic lzo and gzip by not checking for it
+ sed -i '/^CHECK_EXT_COMPRESSION_LIB/d' configure.ac || die
+
+ # don't install unwanted files
+ sed -i 's/COPYING INSTALL//' Makefile.am || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --docdir='$(datarootdir)'/doc/${PF} \
+ --without-gflags \
+ --disable-gtest \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ prune_libtool_files
+}
diff --git a/app-arch/snappy/snappy-1.1.2.ebuild b/app-arch/snappy/snappy-1.1.2.ebuild
new file mode 100644
index 000000000000..8d3e8e6dcf7d
--- /dev/null
+++ b/app-arch/snappy/snappy-1.1.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils autotools
+
+DESCRIPTION="A high-speed compression/decompression library by Google"
+HOMEPAGE="https://code.google.com/p/snappy/"
+# upstream uses google drive which has hash-based URLS
+SRC_URI="http://dev.gentoo.org/~radhermit/dist/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+src_prepare() {
+ # Avoid automagic lzo and gzip by not checking for it
+ sed -i '/^CHECK_EXT_COMPRESSION_LIB/d' configure.ac || die
+
+ # don't install unwanted files
+ sed -i 's/COPYING INSTALL//' Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --without-gflags \
+ --disable-gtest \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}