summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/plextor-tool/files/plextor-tool-0.5.0-build.patch4
-rw-r--r--app-cdr/plextor-tool/plextor-tool-0.5.0.ebuild21
-rw-r--r--app-cdr/xbiso/files/xbiso-0.6.1-libs.patch4
-rw-r--r--app-cdr/xbiso/xbiso-0.6.1-r2.ebuild33
-rw-r--r--app-cdr/xbiso/xbiso-0.6.1-r3.ebuild2
5 files changed, 20 insertions, 44 deletions
diff --git a/app-cdr/plextor-tool/files/plextor-tool-0.5.0-build.patch b/app-cdr/plextor-tool/files/plextor-tool-0.5.0-build.patch
index d2a181f14fed..f01aa00d920b 100644
--- a/app-cdr/plextor-tool/files/plextor-tool-0.5.0-build.patch
+++ b/app-cdr/plextor-tool/files/plextor-tool-0.5.0-build.patch
@@ -1,5 +1,5 @@
---- Makefile
-+++ Makefile
+--- a/Makefile
++++ b/Makefile
@@ -2,17 +2,17 @@
# Copyright (c) 1999-2002 Georg Huettenegger
#
diff --git a/app-cdr/plextor-tool/plextor-tool-0.5.0.ebuild b/app-cdr/plextor-tool/plextor-tool-0.5.0.ebuild
index 39a125aaf854..0822d71769e4 100644
--- a/app-cdr/plextor-tool/plextor-tool-0.5.0.ebuild
+++ b/app-cdr/plextor-tool/plextor-tool-0.5.0.ebuild
@@ -1,34 +1,43 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils toolchain-funcs
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="Tool to change the parameters of a Plextor CD-ROM drive"
HOMEPAGE="http://plextor-tool.sourceforge.net/"
SRC_URI="mirror://sourceforge/plextor-tool/${P}.src.tar.bz2"
+S="${WORKDIR}"/${PN}/src
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="static"
-S=${WORKDIR}/${PN}/src
+PATCHES=(
+ "${FILESDIR}"/${P}-build.patch
+)
src_prepare() {
- epatch "${FILESDIR}"/${P}-build.patch
+ default
+
gunzip plextor-tool.8.gz || die
}
src_compile() {
local targets="plextor-tool"
+
use static && targets="${targets} pt-static"
- echo ${targets} > my-make-targets
+
+ echo ${targets} > my-make-targets || die
+
emake CC="$(tc-getCC)" ${targets}
}
src_install() {
local targets=$(<my-make-targets)
+
dodoc ../doc/{NEWS,README} TODO
dobin ${targets}
doman plextor-tool.8
diff --git a/app-cdr/xbiso/files/xbiso-0.6.1-libs.patch b/app-cdr/xbiso/files/xbiso-0.6.1-libs.patch
index 32b3523d9c92..0b867751c373 100644
--- a/app-cdr/xbiso/files/xbiso-0.6.1-libs.patch
+++ b/app-cdr/xbiso/files/xbiso-0.6.1-libs.patch
@@ -1,5 +1,5 @@
---- a/configure.in 2014-12-02 18:56:23.000000000 +0300
-+++ b/configure.in 2014-12-02 19:09:46.724190436 +0300
+--- a/configure.in
++++ b/configure.in
@@ -6,13 +6,13 @@
dnl Checks for libraries.
diff --git a/app-cdr/xbiso/xbiso-0.6.1-r2.ebuild b/app-cdr/xbiso/xbiso-0.6.1-r2.ebuild
deleted file mode 100644
index 9340e06f7dce..000000000000
--- a/app-cdr/xbiso/xbiso-0.6.1-r2.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit autotools eutils flag-o-matic
-
-DESCRIPTION="Xbox xdvdfs ISO extraction utility"
-HOMEPAGE="https://sourceforge.net/projects/xbiso/"
-SRC_URI="mirror://sourceforge/xbiso/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
-
-src_prepare() {
- sed -i -e 's:C) $(CFLAGS):C) $(LDFLAGS) $(CFLAGS):' Makefile.in || die #337769
- epatch "${FILESDIR}/${P}-libs.patch"
- mv configure.in configure.ac || die #426262
- eautoreconf
-}
-
-src_configure() {
- # for this package, interix behaves the same as BSD
- [[ ${CHOST} == *-interix* ]] && append-flags -D_BSD
-
- econf --disable-ftp
-}
-
-src_install() {
- dobin xbiso
- dodoc CHANGELOG README
-}
diff --git a/app-cdr/xbiso/xbiso-0.6.1-r3.ebuild b/app-cdr/xbiso/xbiso-0.6.1-r3.ebuild
index 5894d4c30c22..6d770560ed44 100644
--- a/app-cdr/xbiso/xbiso-0.6.1-r3.ebuild
+++ b/app-cdr/xbiso/xbiso-0.6.1-r3.ebuild
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/xbiso/${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE=""
src_prepare() {