summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/gptel/gptel-0.9.6.ebuild')
-rw-r--r--app-emacs/gptel/gptel-0.9.6.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-emacs/gptel/gptel-0.9.6.ebuild b/app-emacs/gptel/gptel-0.9.6.ebuild
new file mode 100644
index 000000000000..783dad3ec302
--- /dev/null
+++ b/app-emacs/gptel/gptel-0.9.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS="27.1"
+
+inherit elisp
+
+DESCRIPTION="Simple Large Language Model chat client for GNU Emacs"
+HOMEPAGE="https://github.com/karthink/gptel/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/karthink/${PN}.git"
+else
+ SRC_URI="https://github.com/karthink/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/compat-30.0.0.0
+ app-emacs/transient
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests ert test -l gptel-org -l gptel-org-test
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}