summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/sml-mode')
-rw-r--r--app-emacs/sml-mode/Manifest1
-rw-r--r--app-emacs/sml-mode/sml-mode-6.10.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/app-emacs/sml-mode/Manifest b/app-emacs/sml-mode/Manifest
index 7284b51912f5..463d4cfd27b8 100644
--- a/app-emacs/sml-mode/Manifest
+++ b/app-emacs/sml-mode/Manifest
@@ -1 +1,2 @@
+DIST sml-mode-6.10.el.xz 20544 BLAKE2B c872b33ffb9298dfa102b97d33604c68610d73942698b1162ed5b73fc3107217d453c475c9b0bd51368b5f32f82c147ab8de1990e4277f878837824b5dd004b8 SHA512 49e93cb2d317f0e71bfe66a6b206515eaad2cb5173552e96690fc208e9dd0c448f9939e28cd5268f0e9a90278b821109231885452785345698bee9511577828c
DIST sml-mode-6.9.el.xz 20368 BLAKE2B 5b97c6620d97a60f29e21e8d69179e33f56b7410bf975238e23ef10d4c9e8d7dc250cb60d1799224ac6c81285f539cbb7f69b616763b347ed7140b9652b9add7 SHA512 e04143e1017317d6c6fb3ad7a26cd812bb45dd406a5fb679be21ae936ab57739bcf692585d5710a8e08c469a07728a20cb71ff1b53661c4040eb16df55c8be0b
diff --git a/app-emacs/sml-mode/sml-mode-6.10.ebuild b/app-emacs/sml-mode/sml-mode-6.10.ebuild
new file mode 100644
index 000000000000..ab2cc79cee64
--- /dev/null
+++ b/app-emacs/sml-mode/sml-mode-6.10.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="Emacs major mode for editing Standard ML"
+HOMEPAGE="https://elpa.gnu.org/packages/sml-mode.html
+ http://www.iro.umontreal.ca/~monnier/elisp/"
+# taken from https://elpa.gnu.org/packages/${P}.el
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.el.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+
+SITEFILE="50${PN}-gentoo-6.1.el"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}