summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/fdutils')
-rw-r--r--app-misc/fdutils/fdutils-5.5.20060227-r1.ebuild4
-rw-r--r--app-misc/fdutils/fdutils-5.5.20060227.ebuild4
-rw-r--r--app-misc/fdutils/files/fdutils-5.5.20060227-gcc10.patch20
3 files changed, 26 insertions, 2 deletions
diff --git a/app-misc/fdutils/fdutils-5.5.20060227-r1.ebuild b/app-misc/fdutils/fdutils-5.5.20060227-r1.ebuild
index d234389a9e19..b0196c0d391c 100644
--- a/app-misc/fdutils/fdutils-5.5.20060227-r1.ebuild
+++ b/app-misc/fdutils/fdutils-5.5.20060227-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -26,6 +26,8 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${PN}-5.5-20060227
src_prepare() {
+ epatch "${FILESDIR}/${P}-gcc10.patch"
+
local d="${WORKDIR}"/debian/patches
EPATCH_SOURCE="${d}" epatch $(<"${d}"/series)
sed -i -e 's:{LDFLAFS}:(LDFLAGS):' src/Makefile.in || die #337721
diff --git a/app-misc/fdutils/fdutils-5.5.20060227.ebuild b/app-misc/fdutils/fdutils-5.5.20060227.ebuild
index 1116db851a7f..632a26a8982b 100644
--- a/app-misc/fdutils/fdutils-5.5.20060227.ebuild
+++ b/app-misc/fdutils/fdutils-5.5.20060227.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -25,6 +25,8 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${PN}-5.5-20060227
src_prepare() {
+ epatch "${FILESDIR}/${P}-gcc10.patch"
+
local d="${WORKDIR}"/debian/patches
EPATCH_SOURCE="${d}" epatch $(<"${d}"/series)
sed -i -e 's:{LDFLAFS}:(LDFLAGS):' src/Makefile.in || die #337721
diff --git a/app-misc/fdutils/files/fdutils-5.5.20060227-gcc10.patch b/app-misc/fdutils/files/fdutils-5.5.20060227-gcc10.patch
new file mode 100644
index 000000000000..2bda41e11255
--- /dev/null
+++ b/app-misc/fdutils/files/fdutils-5.5.20060227-gcc10.patch
@@ -0,0 +1,20 @@
+Description: Fix ftbfs with GCC-10
+
+Author: Sudip Mukherjee <sudipm.mukherjee@gmail.com>
+Bug-Debian: https://bugs.debian.org/957200
+Forwarded: no
+
+---
+
+--- fdutils-5.5-20060227.orig/src/superformat.h
++++ fdutils-5.5-20060227/src/superformat.h
+@@ -97,7 +97,7 @@ int compute_all_sequences(struct params
+ void compute_track0_sequence(struct params *fd);
+ int calc_skews(struct params *fd0, struct params *fd, int n);
+ extern int verbosity;
+-int header_size;
+-int index_size;
++extern int header_size;
++extern int index_size;
+
+ #endif