summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/icdiff/icdiff-1.7.3.ebuild')
-rw-r--r--app-misc/icdiff/icdiff-1.7.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-misc/icdiff/icdiff-1.7.3.ebuild b/app-misc/icdiff/icdiff-1.7.3.ebuild
new file mode 100644
index 000000000000..5c53d1f78c31
--- /dev/null
+++ b/app-misc/icdiff/icdiff-1.7.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=(python2_7 python3_4 python3_5)
+
+inherit distutils-r1
+
+DESCRIPTION="Colourized diff that supports side-by-side diffing"
+HOMEPAGE="http://www.jefftk.com/icdiff"
+SRC_URI="https://github.com/jeffkaufman/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.7.3-dont-check-changelog.patch"
+)
+
+DOCS=(README.md ChangeLog)
+
+S="${WORKDIR}/${PN}-release-${PV}"
+
+python_test() {
+ ./test.sh "${EPYTHON%.*}" || die "Tests failed"
+}