summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/webcomics-collector/webcomics-collector-0.7.3.ebuild')
-rw-r--r--app-misc/webcomics-collector/webcomics-collector-0.7.3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-misc/webcomics-collector/webcomics-collector-0.7.3.ebuild b/app-misc/webcomics-collector/webcomics-collector-0.7.3.ebuild
new file mode 100644
index 000000000000..e3e1b776eefe
--- /dev/null
+++ b/app-misc/webcomics-collector/webcomics-collector-0.7.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="gdbm"
+
+inherit distutils
+
+DESCRIPTION="python script for downloading webcomics"
+HOMEPAGE="http://collector.skumleren.net/"
+SRC_URI="http://collector.skumleren.net/releases/collector-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/collector-${PV}"
+
+DOCS="UPGRADE"
+PYTHON_MODNAME="Collector.py"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ ewarn "If you are upgrading from an earlier version of Collector, please"
+ ewarn "read UPGRADE. This new version will not be able to use your old"
+ ewarn "archives if you do not follow the upgrade instructions!"
+}