summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/openrgb/files/OpenRGB-0.7-plugins.patch24
-rw-r--r--app-misc/openrgb/openrgb-9999.ebuild3
2 files changed, 25 insertions, 2 deletions
diff --git a/app-misc/openrgb/files/OpenRGB-0.7-plugins.patch b/app-misc/openrgb/files/OpenRGB-0.7-plugins.patch
new file mode 100644
index 000000000000..b9a6fb2cd16a
--- /dev/null
+++ b/app-misc/openrgb/files/OpenRGB-0.7-plugins.patch
@@ -0,0 +1,24 @@
+Allow installation of plugins not only in ~/.config
+
+Used by app-misc/openrgb-plugin-* packages
+
+--- a/PluginManager.cpp
++++ b/PluginManager.cpp
+@@ -35,7 +35,8 @@ void PluginManager::ScanAndLoadPlugins()
+ | The plugins directory is a directory named "plugins" in |
+ | the configuration directory |
+ \*---------------------------------------------------------*/
+- const QDir plugins_dir = QString().fromStdString(ResourceManager::get()->GetConfigurationDirectory()) + "plugins/";
++ for (const QDir plugins_dir : {QString().fromStdString(ResourceManager::get()->GetConfigurationDirectory()) + "plugins/",
++ QString().fromStdString(GENTOO_PLUGINS_DIR)}) {
+
+ /*---------------------------------------------------------*\
+ | Get a list of all files in the plugins directory |
+@@ -56,6 +57,7 @@ void PluginManager::ScanAndLoadPlugins()
+
+ AddPlugin(plugin_path);
+ }
++ }
+ }
+
+ void PluginManager::AddPlugin(std::string path)
diff --git a/app-misc/openrgb/openrgb-9999.ebuild b/app-misc/openrgb/openrgb-9999.ebuild
index 9ea0dfa538ff..a3d6ddefcc41 100644
--- a/app-misc/openrgb/openrgb-9999.ebuild
+++ b/app-misc/openrgb/openrgb-9999.ebuild
@@ -39,8 +39,7 @@ BDEPEND="
"
PATCHES+=(
- "${FILESDIR}"/OpenRGB-0.6-pkgconf.patch
- "${FILESDIR}"/OpenRGB-0.6-plugins.patch
+ "${FILESDIR}"/OpenRGB-0.7-plugins.patch
)
src_prepare() {