summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/asciidoc/asciidoc-9999.ebuild')
-rw-r--r--app-text/asciidoc/asciidoc-9999.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/app-text/asciidoc/asciidoc-9999.ebuild b/app-text/asciidoc/asciidoc-9999.ebuild
index 3e19725242a1..0a4f1a949fe4 100644
--- a/app-text/asciidoc/asciidoc-9999.ebuild
+++ b/app-text/asciidoc/asciidoc-9999.ebuild
@@ -7,7 +7,7 @@ EAPI=5
PYTHON_COMPAT=( python2_7 pypy )
[ "$PV" == "9999" ] && inherit mercurial autotools
-inherit python-single-r1
+inherit readme.gentoo python-single-r1
DESCRIPTION="AsciiDoc is a plain text human readable/writable document format"
HOMEPAGE="http://www.methods.co.nz/asciidoc/"
@@ -17,7 +17,7 @@ if [ "$PV" == "9999" ]; then
KEYWORDS=""
else
SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
fi
LICENSE="GPL-2"
@@ -30,8 +30,6 @@ RDEPEND=">=app-text/docbook-xsl-stylesheets-1.75
dev-libs/libxslt
graphviz? ( media-gfx/graphviz )
app-text/docbook-xml-dtd:4.5
- app-text/dblatex
- || ( www-client/w3m www-client/lynx )
highlight? ( || ( dev-util/source-highlight \
dev-python/pygments[${PYTHON_USEDEP}] \
app-text/highlight )
@@ -47,6 +45,11 @@ DEPEND="test? ( dev-util/source-highlight
${PYTHON_DEPS} )
"
+DOC_CONTENTS="
+If you are going to use a2x, please also look at a2x(1) under
+REQUISITES for a list of runtime dependencies.
+"
+
if [ "$PV" == "9999" ]; then
DEPEND="${DEPEND}
dev-util/aap
@@ -100,6 +103,7 @@ src_install() {
dosym ../../../asciidoc/images /usr/share/doc/${PF}/examples
fi
+ readme.gentoo.create_doc
dodoc BUGS CHANGELOG README docbook-xsl/asciidoc-docbook-xsl.txt \
dblatex/dblatex-readme.txt filters/code/code-filter-readme.txt
}