summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/libgepub/libgepub-0.4.ebuild')
-rw-r--r--app-text/libgepub/libgepub-0.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-text/libgepub/libgepub-0.4.ebuild b/app-text/libgepub/libgepub-0.4.ebuild
new file mode 100644
index 000000000000..d2854c747225
--- /dev/null
+++ b/app-text/libgepub/libgepub-0.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit gnome2
+
+DESCRIPTION="GObject based library for handling and rendering epub documents"
+HOMEPAGE="https://git.gnome.org/browse/libgepub"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection"
+
+RDEPEND="
+ app-arch/libarchive
+ dev-libs/glib:2
+ dev-libs/libxml2
+ net-libs/libsoup:2.4
+ net-libs/webkit-gtk:4
+ x11-libs/gtk+:3
+ introspection? ( >=dev-libs/gobject-introspection-1.30:= )
+"
+DEPEND="${RDEPEND}
+ gnome-base/gnome-common
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection)
+}