summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/xapian-omega/xapian-omega-1.3.4.ebuild')
-rw-r--r--app-text/xapian-omega/xapian-omega-1.3.4.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/app-text/xapian-omega/xapian-omega-1.3.4.ebuild b/app-text/xapian-omega/xapian-omega-1.3.4.ebuild
index d38795598d69..a48191a465ce 100644
--- a/app-text/xapian-omega/xapian-omega-1.3.4.ebuild
+++ b/app-text/xapian-omega/xapian-omega-1.3.4.ebuild
@@ -4,6 +4,8 @@
EAPI="5"
+inherit autotools eutils
+
DESCRIPTION="An application built on Xapian, consisting of indexers and a CGI search frontend"
SRC_URI="http://www.oligarchy.co.uk/xapian/${PV}/xapian-omega-${PV}.tar.xz"
HOMEPAGE="http://www.xapian.org/"
@@ -20,6 +22,12 @@ DEPEND="dev-libs/xapian:0/1.3.5
sys-libs/zlib"
RDEPEND="${DEPEND}"
+src_prepare() {
+ # Bug #574666
+ epatch "${FILESDIR}"/${P}-fix-lz.patch
+ eautoreconf
+}
+
src_install () {
emake DESTDIR="${D}" install