summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/rust-vim')
-rw-r--r--app-vim/rust-vim/Manifest1
-rw-r--r--app-vim/rust-vim/metadata.xml3
-rw-r--r--app-vim/rust-vim/rust-vim-1_pre20160829.ebuild18
3 files changed, 22 insertions, 0 deletions
diff --git a/app-vim/rust-vim/Manifest b/app-vim/rust-vim/Manifest
index 4b772f0ce0cb..14fe9b03b7e8 100644
--- a/app-vim/rust-vim/Manifest
+++ b/app-vim/rust-vim/Manifest
@@ -1 +1,2 @@
DIST rust-mode-vim-1_beta20150411.tar.gz 14834 SHA256 ae10727c14612905f489afea1146bac24a0ea6309a3a3fcf97a048dd1e156eb4 SHA512 f841768909203475a0cd3589a148d334001351fb23976ee28823a9dbde396d89a4f3c5ac07166420c8ddb64692dcc86b98b3afc3579171115a3a2af17b6aa449 WHIRLPOOL c95fc23f40608be817c7fc7467138efaa25a6b24427b79ab0de7daf84e5f32c4f2cd0db1377e2eaa0e40bf83cb765c86f6e04752b142b1779c194ceddc8b7d07
+DIST rust-vim-1_pre20160829.tar.gz 23801 SHA256 43234612d8a5ecdb6c4e988dcf14dc15b0c7c9b473591024b12cbeb09eb187e5 SHA512 bfd9290f03f3fb0ffccbc1d78f9e37c5d3ca57379f0b505e84b445105bd5a011f623f402d35407a634eaef4db9ad3fea68517057aa4d84e99206bc99067daa3d WHIRLPOOL b004a6d2fd63833d658ba2dcf38bfd2dc8e39fcac75b6dddae56a47a8b288908a9e613d12d75e0380e6443bfff38c49204c829be0a2502bce28b64fd68014a89
diff --git a/app-vim/rust-vim/metadata.xml b/app-vim/rust-vim/metadata.xml
index 3554bdb770b5..170cf0d86713 100644
--- a/app-vim/rust-vim/metadata.xml
+++ b/app-vim/rust-vim/metadata.xml
@@ -9,4 +9,7 @@
<email>proxy-maint@gentoo.org</email>
<name>Gentoo Proxy Maintainers Project</name>
</maintainer>
+ <upstream>
+ <remote-id type="github">rust-lang/rust.vim</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/app-vim/rust-vim/rust-vim-1_pre20160829.ebuild b/app-vim/rust-vim/rust-vim-1_pre20160829.ebuild
new file mode 100644
index 000000000000..c534804489f8
--- /dev/null
+++ b/app-vim/rust-vim/rust-vim-1_pre20160829.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit vim-plugin vcs-snapshot
+
+MY_PN="${PN/-/.}"
+REF="fc11d02fee330df7b30c83a80f09dd0c60ab43ce"
+
+DESCRIPTION="Vim configuration for Rust"
+HOMEPAGE="http://www.rust-lang.org/"
+SRC_URI="https://github.com/rust-lang/${MY_PN}/tarball/${REF} -> ${P}.tar.gz"
+
+LICENSE="|| ( MIT Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"