summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/sudoedit')
-rw-r--r--app-vim/sudoedit/Manifest2
-rw-r--r--app-vim/sudoedit/metadata.xml8
-rw-r--r--app-vim/sudoedit/sudoedit-0.20.ebuild19
-rw-r--r--app-vim/sudoedit/sudoedit-0.21.ebuild19
4 files changed, 48 insertions, 0 deletions
diff --git a/app-vim/sudoedit/Manifest b/app-vim/sudoedit/Manifest
new file mode 100644
index 000000000000..1d599bd8cd7a
--- /dev/null
+++ b/app-vim/sudoedit/Manifest
@@ -0,0 +1,2 @@
+DIST sudoedit-0.20.tar.bz2 11420 SHA256 a9b274e38025e21bc7be430878e8bf1f1a131620236de397f8a99cd651d72384 SHA512 963815cd9c41b54bf1a3aee259460565f4cfe6d5f9d32b5b9986026e2666e1913c89a59706aafc604dbad433d706e4a9cbf533cc7bfe978eb9a0de2194540ebf WHIRLPOOL b6eac2b628252a576656fd0101b7a2afee29acc4c2ca09b535f7320fe13c0408a9c4e415b5cb7a36966b6a95c43d28907302c00c5103994f6debc996338ad25a
+DIST sudoedit-0.21.tar.bz2 12483 SHA256 b877c19aaa4f7440b611eafbca4a903f39c5ab5dc19d90eeb54ae3d1ba520e4c SHA512 60d5fde0ef82c4ccba2b62c75651cb1ed1dfc2a4e2815785dcaf4e515222a4d2bed193cdd8323a742109cb43a4123d27db39776a562b150b93ffdb9beec12d3c WHIRLPOOL f15eb65d7c5f583e6ee7c39c889d14f94aae7157995fa69e124a82b44783a6c947e42df89b5b739b7ed61347c4c9cee8706ec66f8d587c3478ced7f03a841ff3
diff --git a/app-vim/sudoedit/metadata.xml b/app-vim/sudoedit/metadata.xml
new file mode 100644
index 000000000000..21a3d28e47f3
--- /dev/null
+++ b/app-vim/sudoedit/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+ <upstream>
+ <remote-id type="github">chrisbra/SudoEdit.vim</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/sudoedit/sudoedit-0.20.ebuild b/app-vim/sudoedit/sudoedit-0.20.ebuild
new file mode 100644
index 000000000000..caa1fc4488e1
--- /dev/null
+++ b/app-vim/sudoedit/sudoedit-0.20.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: edit files using sudo or su"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2709 https://github.com/chrisbra/SudoEdit.vim"
+LICENSE="vim"
+KEYWORDS="~amd64 ~x86"
+VIM_PLUGIN_HELPFILES="SudoEdit.txt"
+
+RDEPEND="|| ( app-admin/sudo sys-apps/shadow )"
+
+src_prepare() {
+ # remove unused windows related file
+ rm autoload/sudo.cmd || die
+}
diff --git a/app-vim/sudoedit/sudoedit-0.21.ebuild b/app-vim/sudoedit/sudoedit-0.21.ebuild
new file mode 100644
index 000000000000..79c63354ee6a
--- /dev/null
+++ b/app-vim/sudoedit/sudoedit-0.21.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: edit files using sudo or su"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2709 https://github.com/chrisbra/SudoEdit.vim"
+LICENSE="vim"
+KEYWORDS="~amd64 ~x86"
+VIM_PLUGIN_HELPFILES="SudoEdit.txt"
+
+RDEPEND="|| ( app-admin/sudo sys-apps/shadow )"
+
+src_prepare() {
+ # remove unused windows related files
+ rm autoload/{sudo.cmd,SudoEdit.vbs} || die
+}