summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/gtest/gtest-9999.ebuild')
-rw-r--r--dev-cpp/gtest/gtest-9999.ebuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/dev-cpp/gtest/gtest-9999.ebuild b/dev-cpp/gtest/gtest-9999.ebuild
index b0cdccd02275..f86a47387a97 100644
--- a/dev-cpp/gtest/gtest-9999.ebuild
+++ b/dev-cpp/gtest/gtest-9999.ebuild
@@ -34,6 +34,9 @@ RESTRICT="!test? ( test )"
BDEPEND="test? ( ${PYTHON_DEPS} )"
+# Exclude tests that fail with FEATURES="usersandbox"
+CMAKE_SKIP_TESTS=( "googletest-(death-test|port)-test" )
+
pkg_setup() {
use test && python-any-r1_pkg_setup
}
@@ -61,11 +64,6 @@ multilib_src_configure() {
cmake_src_configure
}
-multilib_src_test() {
- # Exclude tests that fail with FEATURES="usersandbox"
- cmake_src_test -E "googletest-(death-test|port)-test"
-}
-
multilib_src_install_all() {
einstalldocs