summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-debug/gdb/gdb-9999.ebuild')
-rw-r--r--dev-debug/gdb/gdb-9999.ebuild17
1 files changed, 14 insertions, 3 deletions
diff --git a/dev-debug/gdb/gdb-9999.ebuild b/dev-debug/gdb/gdb-9999.ebuild
index c35dad1f342f..90eaaa3ee62d 100644
--- a/dev-debug/gdb/gdb-9999.ebuild
+++ b/dev-debug/gdb/gdb-9999.ebuild
@@ -6,8 +6,9 @@ EAPI=8
# See https://sourceware.org/gdb/wiki/DistroAdvice for general packaging
# tips & notes.
+GUILE_COMPAT=( 2-2 3-0 )
PYTHON_COMPAT=( python3_{10..12} )
-inherit flag-o-matic python-single-r1 strip-linguas toolchain-funcs
+inherit flag-o-matic guile-single python-single-r1 strip-linguas toolchain-funcs
export CTARGET=${CTARGET:-${CHOST}}
@@ -76,7 +77,10 @@ IUSE="cet debuginfod guile lzma multitarget nls +python +server sim source-highl
if [[ -n ${REGULAR_RELEASE} ]] ; then
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
fi
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+REQUIRED_USE="
+ guile? ( ${GUILE_REQUIRED_USE} )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
RESTRICT="!test? ( test )"
RDEPEND="
@@ -91,7 +95,7 @@ RDEPEND="
)
lzma? ( app-arch/xz-utils )
python? ( ${PYTHON_DEPS} )
- guile? ( >=dev-scheme/guile-2.0 )
+ guile? ( ${GUILE_DEPS} )
xml? ( dev-libs/expat )
source-highlight? (
dev-util/source-highlight
@@ -115,17 +119,22 @@ QA_CONFIG_IMPL_DECL_SKIP=(
MIN # gnulib FP (bug #898688)
)
+QA_PREBUILT="usr/share/gdb/guile/*"
+
PATCHES=(
"${FILESDIR}"/${PN}-8.3.1-verbose-build.patch
)
pkg_setup() {
+ use guile && guile-single_pkg_setup
use python && python-single-r1_pkg_setup
}
src_prepare() {
default
+ use guile && guile_bump_sources
+
strip-linguas -u bfd/po opcodes/po
# Avoid using ancient termcap from host on Prefix systems
@@ -303,6 +312,8 @@ src_install() {
# Remove shared info pages
rm -f "${ED}"/usr/share/info/{annotate,bfd,configure,ctf-spec,standards}.info*
+ use guile && guile_unstrip_ccache
+
if use python ; then
python_optimize "${ED}"/usr/share/gdb/python/gdb
fi