summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-debug/strace/strace-6.7.ebuild')
-rw-r--r--dev-debug/strace/strace-6.7.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/dev-debug/strace/strace-6.7.ebuild b/dev-debug/strace/strace-6.7.ebuild
index c380af2dcd29..7c8d69f65cc5 100644
--- a/dev-debug/strace/strace-6.7.ebuild
+++ b/dev-debug/strace/strace-6.7.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools edo flag-o-matic toolchain-funcs
+inherit autotools edo flag-o-matic toolchain-funcs verify-sig
DESCRIPTION="Useful diagnostic, instructional, and debugging tool"
HOMEPAGE="https://strace.io/"
@@ -12,17 +12,25 @@ if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://github.com/strace/strace.git"
inherit git-r3
else
- SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
+ SRC_URI="
+ https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz
+ verify-sig? ( https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz.asc )
+ "
KEYWORDS="~alpha amd64 arm arm64 hppa ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
fi
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/strace.asc
+
LICENSE="LGPL-2.1+ test? ( GPL-2+ )"
SLOT="0"
IUSE="aio perl selinux static test unwind elfutils"
RESTRICT="!test? ( test )"
REQUIRED_USE="?? ( unwind elfutils )"
-BDEPEND="virtual/pkgconfig"
+BDEPEND="
+ virtual/pkgconfig
+ verify-sig? ( >=sec-keys/openpgp-keys-strace-20151021 )
+"
LIB_DEPEND="
unwind? ( sys-libs/libunwind[static-libs(+)] )
elfutils? ( dev-libs/elfutils[static-libs(+)] )