summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet/notify-sharp')
-rw-r--r--dev-dotnet/notify-sharp/Manifest1
-rw-r--r--dev-dotnet/notify-sharp/files/notify-sharp-0.4.0_pre20080912-control-docs.patch28
-rw-r--r--dev-dotnet/notify-sharp/files/notify-sharp-0.4.0_pre20090305-dbus-sharp.patch60
-rw-r--r--dev-dotnet/notify-sharp/metadata.xml5
-rw-r--r--dev-dotnet/notify-sharp/notify-sharp-0.4.0_pre20090305.ebuild36
5 files changed, 130 insertions, 0 deletions
diff --git a/dev-dotnet/notify-sharp/Manifest b/dev-dotnet/notify-sharp/Manifest
new file mode 100644
index 000000000000..e52164f1e6f1
--- /dev/null
+++ b/dev-dotnet/notify-sharp/Manifest
@@ -0,0 +1 @@
+DIST notify-sharp-20090305.tar.bz2 79020 SHA256 67101c024f28209181ad5b62e4f4cfa038e362f808c1511d95b21a1a698731f2 SHA512 2daf6d33b3a4f53445193a654c3a92cd8e3766772472a914aa12a1c8619e5d48ed954987c44c3d856faec2e0a03e3348f6b4809a615ea3cfb4ef17ef5000c686 WHIRLPOOL a59b21e987613644a3eec4a04848f7219a318f7ef1a66e9d34b67b3621835d382b7874d13e0134658f0e4092c4651198475c55ba2231264053ebefbadd9c36c2
diff --git a/dev-dotnet/notify-sharp/files/notify-sharp-0.4.0_pre20080912-control-docs.patch b/dev-dotnet/notify-sharp/files/notify-sharp-0.4.0_pre20080912-control-docs.patch
new file mode 100644
index 000000000000..44ff05881fb4
--- /dev/null
+++ b/dev-dotnet/notify-sharp/files/notify-sharp-0.4.0_pre20080912-control-docs.patch
@@ -0,0 +1,28 @@
+diff -NrU5 notify-sharp-20080912.orig/configure.ac notify-sharp-20080912/configure.ac
+--- notify-sharp-20080912.orig/configure.ac 2008-11-26 21:56:02.000000000 +0100
++++ notify-sharp-20080912/configure.ac 2008-11-26 22:01:08.000000000 +0100
+@@ -34,16 +34,21 @@
+ if test "x$GACUTIL" = "xno"; then
+ AC_MSG_ERROR([You need to install gacutil])
+ fi
+ AC_SUBST(GACUTIL)
+
+-AC_ARG_ENABLE(docs, AC_HELP_STRING([--disable-docs],
+- [Do not build documentation]), with_docs=no, with_docs=yes)
++AC_ARG_ENABLE( [docs],
++ [AC_HELP_STRING( [--enable/disable-docs],
++ [Do (not) build documentation (default=yes)]
++ )],
++ [],
++ [enable_docs=yes]
++)
+
+ MONODOC_REQ_VERSION=1.1.18
+
+-if test "x$with_docs" = "xyes"; then
++if test "x$enable_docs" = "xyes"; then
+ PKG_CHECK_MODULES(MONODOC, monodoc >= $MONODOC_REQ_VERSION,,
+ [AC_MSG_ERROR([You need to install monodoc, or pass --disable-docs to configure to skip documentation installation])])
+ AC_PATH_PROG(MONODOCER, monodocer, no)
+ if test "x$MONODOCER" = "xno"; then
+ AC_MSG_ERROR([You need to install monodoc, or pass --disable-docs to configure to skip documentation installation])
diff --git a/dev-dotnet/notify-sharp/files/notify-sharp-0.4.0_pre20090305-dbus-sharp.patch b/dev-dotnet/notify-sharp/files/notify-sharp-0.4.0_pre20090305-dbus-sharp.patch
new file mode 100644
index 000000000000..28c6316dc5aa
--- /dev/null
+++ b/dev-dotnet/notify-sharp/files/notify-sharp-0.4.0_pre20090305-dbus-sharp.patch
@@ -0,0 +1,60 @@
+diff --git a/configure.ac b/configure.ac
+index d2ff635..7200f06 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -71,11 +71,11 @@ GTK_SHARP_REQ_VERSION=2.10.1
+ PKG_CHECK_MODULES(GTK_SHARP, gtk-sharp-2.0 >= $GTK_SHARP_REQ_VERSION)
+ AC_SUBST(GTK_SHARP_LIBS)
+
+-NDESK_DBUS_REQ_VERSION=0.4
+-NDESK_DBUS_GLIB_REQ_VERSION=0.3
+-PKG_CHECK_MODULES(NDESK_DBUS, ndesk-dbus-1.0 >= $NDESK_DBUS_REQ_VERSION \
+- ndesk-dbus-glib-1.0 >= $NDESK_DBUS_GLIB_REQ_VERSION)
+-AC_SUBST(NDESK_DBUS_LIBS)
++DBUS_SHARP_REQ_VERSION=0.7
++DBUS_SHARP_GLIB_REQ_VERSION=0.5
++PKG_CHECK_MODULES(DBUS_SHARP, dbus-sharp-1.0 >= $DBUS_SHARP_REQ_VERSION \
++ dbus-sharp-glib-1.0 >= $DBUS_SHARP_GLIB_REQ_VERSION)
++AC_SUBST(DBUS_SHARP_LIBS)
+
+ required_assemblies="Mono.Posix"
+
+diff --git a/src/Global.cs b/src/Global.cs
+index eedefbf..a0f80ed 100644
+--- a/src/Global.cs
++++ b/src/Global.cs
+@@ -24,7 +24,7 @@ using System;
+ using System.Reflection;
+ using System.Collections.Generic;
+
+-using NDesk.DBus;
++using DBus;
+ using org.freedesktop;
+ using org.freedesktop.DBus;
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 3b39c23..50bbb39 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -7,7 +7,7 @@ CSFLAGS = \
+ LIBFLAGS = \
+ -r:Mono.Posix \
+ $(GTK_SHARP_LIBS) \
+- $(NDESK_DBUS_LIBS)
++ $(DBUS_SHARP_LIBS)
+
+ CSFILES = \
+ $(srcdir)/Global.cs \
+diff --git a/src/Notification.cs b/src/Notification.cs
+index 09ef83e..e2ab72f 100644
+--- a/src/Notification.cs
++++ b/src/Notification.cs
+@@ -28,7 +28,7 @@ using GLib;
+ using Gdk;
+ using Gtk;
+
+-using NDesk.DBus;
++using DBus;
+ using org.freedesktop;
+ using org.freedesktop.DBus;
+
diff --git a/dev-dotnet/notify-sharp/metadata.xml b/dev-dotnet/notify-sharp/metadata.xml
new file mode 100644
index 000000000000..e01adbb307db
--- /dev/null
+++ b/dev-dotnet/notify-sharp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dotnet</herd>
+</pkgmetadata>
diff --git a/dev-dotnet/notify-sharp/notify-sharp-0.4.0_pre20090305.ebuild b/dev-dotnet/notify-sharp/notify-sharp-0.4.0_pre20090305.ebuild
new file mode 100644
index 000000000000..ae33c3b95e44
--- /dev/null
+++ b/dev-dotnet/notify-sharp/notify-sharp-0.4.0_pre20090305.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils mono
+
+MY_P=${PN}-${PV#*_pre}
+
+DESCRIPTION="a C# client implementation for Desktop Notifications"
+HOMEPAGE="http://www.ndesk.org/NotifySharp"
+SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="doc"
+
+RDEPEND=">=dev-lang/mono-1.1.13
+ >=dev-dotnet/gtk-sharp-2.10.1
+ >=dev-dotnet/dbus-sharp-0.6
+ >=dev-dotnet/dbus-sharp-glib-0.4
+ >=x11-libs/libnotify-0.4.5"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.4.0_pre20080912-control-docs.patch" \
+ "${FILESDIR}/${P}-dbus-sharp.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable doc docs)
+}