summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/extra/extra-1.46.3.ebuild')
-rw-r--r--dev-haskell/extra/extra-1.46.3.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-haskell/extra/extra-1.46.3.ebuild b/dev-haskell/extra/extra-1.46.3.ebuild
new file mode 100644
index 000000000000..551557e39da5
--- /dev/null
+++ b/dev-haskell/extra/extra-1.46.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="Extra"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A grab bag of modules"
+HOMEPAGE="https://github.com/ddssff/haskell-extra"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+network-uri"
+
+RDEPEND="dev-haskell/bzlib:=[profile?]
+ dev-haskell/hunit:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/old-locale:=[profile?]
+ dev-haskell/old-time:=[profile?]
+ dev-haskell/puremd5:=[profile?]
+ >=dev-haskell/quickcheck-2:2=[profile?] <dev-haskell/quickcheck-3:2=[profile?]
+ dev-haskell/random:=[profile?]
+ dev-haskell/regex-compat:=[profile?]
+ >=dev-haskell/unixutils-1.51:=[profile?]
+ dev-haskell/zlib:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ network-uri? ( >=dev-haskell/network-uri-2.6:=[profile?] )
+ !network-uri? ( >=dev-haskell/network-2.4:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag network-uri network-uri)
+}