summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/missingh/missingh-1.3.0.1.ebuild')
-rw-r--r--dev-haskell/missingh/missingh-1.3.0.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-haskell/missingh/missingh-1.3.0.1.ebuild b/dev-haskell/missingh/missingh-1.3.0.1.ebuild
new file mode 100644
index 000000000000..b76a2e529247
--- /dev/null
+++ b/dev-haskell/missingh/missingh-1.3.0.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+MY_PN="MissingH"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Large utility library"
+HOMEPAGE="https://github.com/jgoerzen/missingh/wiki"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE=""
+
+RDEPEND="dev-haskell/hslogger:=[profile?]
+ dev-haskell/hunit:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/network:=[profile?]
+ dev-haskell/old-time:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ dev-haskell/random:=[profile?]
+ dev-haskell/regex-compat:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/errorcall-eq-instance
+ dev-haskell/quickcheck
+ dev-haskell/testpack )
+"
+
+S="${WORKDIR}/${MY_P}"