summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/python-3.6.11-r2.ebuild')
-rw-r--r--dev-lang/python/python-3.6.11-r2.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/dev-lang/python/python-3.6.11-r2.ebuild b/dev-lang/python/python-3.6.11-r2.ebuild
index 1fb0d08c9491..ea7d7c2ab712 100644
--- a/dev-lang/python/python-3.6.11-r2.ebuild
+++ b/dev-lang/python/python-3.6.11-r2.ebuild
@@ -4,7 +4,8 @@
EAPI="7"
WANT_LIBTOOL="none"
-inherit autotools flag-o-matic pax-utils python-utils-r1 toolchain-funcs
+inherit autotools flag-o-matic multiprocessing pax-utils \
+ python-utils-r1 toolchain-funcs
MY_P="Python-${PV}"
PYVER=$(ver_cut 1-2)
@@ -81,6 +82,11 @@ src_prepare() {
configure.ac \
setup.py || die "sed failed to replace @@GENTOO_LIBDIR@@"
+ # force correct number of jobs
+ # https://bugs.gentoo.org/737660
+ local jobs=$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")
+ sed -i -e "/self\.parallel/s:True:${jobs}:" setup.py || die
+
eautoreconf
}
@@ -193,10 +199,12 @@ src_test() {
# bug 660358
local -x COLUMNS=80
-
local -x PYTHONDONTWRITEBYTECODE=
- emake test EXTRATESTOPTS="-u-network" CPPFLAGS= CFLAGS= LDFLAGS= < /dev/tty
+ local jobs=$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")
+
+ emake test EXTRATESTOPTS="-u-network -j${jobs}" \
+ CPPFLAGS= CFLAGS= LDFLAGS= < /dev/tty
local result=$?
for test in ${skipped_tests}; do