summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/jansson/jansson-2.14-r1.ebuild')
-rw-r--r--dev-libs/jansson/jansson-2.14-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/jansson/jansson-2.14-r1.ebuild b/dev-libs/jansson/jansson-2.14-r1.ebuild
new file mode 100644
index 000000000000..fb6ee3866f10
--- /dev/null
+++ b/dev-libs/jansson/jansson-2.14-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="C library for encoding, decoding and manipulating JSON data"
+HOMEPAGE="https://www.digip.org/jansson/"
+SRC_URI="https://github.com/akheron/jansson/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/4"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
+IUSE="doc static-libs"
+
+BDEPEND="doc? ( dev-python/sphinx )"
+
+PATCHES=( "${FILESDIR}/${P}-test-symbols.patch" )
+
+src_configure() {
+ tc-ld-force-bfd
+
+ econf $(use_enable static-libs static)
+}
+
+src_compile() {
+ default
+
+ if use doc ; then
+ emake html
+ HTML_DOCS=( "${BUILD_DIR}"/doc/_build/html/. )
+ fi
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}