summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libbase58/libbase58-0.1.4.ebuild')
-rw-r--r--dev-libs/libbase58/libbase58-0.1.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-libs/libbase58/libbase58-0.1.4.ebuild b/dev-libs/libbase58/libbase58-0.1.4.ebuild
new file mode 100644
index 000000000000..55a1b52188cb
--- /dev/null
+++ b/dev-libs/libbase58/libbase58-0.1.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="C implementation of Bitcoin's base58 encoding"
+HOMEPAGE="https://github.com/luke-jr/libbase58"
+LICENSE="MIT"
+
+SRC_URI="https://github.com/luke-jr/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SLOT="0/0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE="tools"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable tools tool)
+}