summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/variantslib')
-rw-r--r--dev-ml/variantslib/Manifest2
-rw-r--r--dev-ml/variantslib/metadata.xml8
-rw-r--r--dev-ml/variantslib/variantslib-109.15.00.ebuild24
-rw-r--r--dev-ml/variantslib/variantslib-109.15.02.ebuild25
4 files changed, 59 insertions, 0 deletions
diff --git a/dev-ml/variantslib/Manifest b/dev-ml/variantslib/Manifest
new file mode 100644
index 000000000000..9d96cf9d1ce9
--- /dev/null
+++ b/dev-ml/variantslib/Manifest
@@ -0,0 +1,2 @@
+DIST variantslib-109.15.00.tar.gz 57154 SHA256 1ab28921e533121b27f6c4fa633277a05fbe3a642ad8c4228d403a06720f6245 SHA512 cfbe7bdf7e447a2f47daaef1b5c8af5063c3d560158582561ab944b411cde67b6cf5d27f5ba7d773621873e67f1f8b9a45cdc0dccc7cc2ea903ca8424d15f1d9 WHIRLPOOL 15c4849c6974e295e3da174356a3df25c95c13dc1e39e9a52df7c97ca7a9cd9d62d031fc005a63594b36ee9095e7c3039c5d9afbcf9cd90f70b94efdb84f34c7
+DIST variantslib-109.15.02.tar.gz 60251 SHA256 3f7bb9f2c9b9bf601a3d0a4a11b270ab6979213780b609060ab3ead9ab59eff4 SHA512 2cdd6c3f9fad0a8ea28357cbf80b69ccc3c73e74404cb4b5439c8c32f6a9f39cacc682cc7375f7a07e948191676506dcf64712869e28a2149d8b8cad5960e529 WHIRLPOOL faadffa83da47a2c4031ccca4696740cb9cecc619637be41f81aa3271a2ba875be0056f14ec13a7c9ab2232149d34e8096feca6f539c8b9ee269e24b4402e72d
diff --git a/dev-ml/variantslib/metadata.xml b/dev-ml/variantslib/metadata.xml
new file mode 100644
index 000000000000..abf9563dd5c5
--- /dev/null
+++ b/dev-ml/variantslib/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ml</herd>
+ <upstream>
+ <remote-id type="bitbucket">yminsky/ocaml-core</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/variantslib/variantslib-109.15.00.ebuild b/dev-ml/variantslib/variantslib-109.15.00.ebuild
new file mode 100644
index 000000000000..5894f5fe700e
--- /dev/null
+++ b/dev-ml/variantslib/variantslib-109.15.00.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="OCaml variants as first class values"
+HOMEPAGE="http://bitbucket.org/yminsky/ocaml-core/wiki/Home"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV}/individual/${P}.tar.gz
+ http://dev.gentoo.org/~aballier/distfiles/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-ml/type-conv-${PV}:="
+RDEPEND="${DEPEND}"
+
+DOCS=( "README.txt" )
diff --git a/dev-ml/variantslib/variantslib-109.15.02.ebuild b/dev-ml/variantslib/variantslib-109.15.02.ebuild
new file mode 100644
index 000000000000..fb43ecbf9314
--- /dev/null
+++ b/dev-ml/variantslib/variantslib-109.15.02.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="OCaml variants as first class values"
+HOMEPAGE="http://bitbucket.org/yminsky/ocaml-core/wiki/Home"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}.00/individual/${P}.tar.gz
+ http://dev.gentoo.org/~aballier/distfiles/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-ml/type-conv-${PV}:=
+ || ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )"
+RDEPEND="${DEPEND}"
+
+DOCS=( "README.txt" )