summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cryptography/files/0.7-setup.patch')
-rw-r--r--dev-python/cryptography/files/0.7-setup.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/cryptography/files/0.7-setup.patch b/dev-python/cryptography/files/0.7-setup.patch
new file mode 100644
index 000000000000..db5cc0239c70
--- /dev/null
+++ b/dev-python/cryptography/files/0.7-setup.patch
@@ -0,0 +1,22 @@
+https://github.com/pyca/cryptography/commit/5bea5ca0233be05e09d8c62fdeae86187e73a48e
+diff --git a/setup.py b/setup.py
+index ead5ec4..32a87ba 100644
+--- a/setup.py
++++ b/setup.py
+@@ -36,12 +36,14 @@
+
+ requirements = [
+ CFFI_DEPENDENCY,
+- "enum34",
+ "pyasn1",
+ SIX_DEPENDENCY,
+ SETUPTOOLS_DEPENDENCY
+ ]
+
++if sys.version_info < (3, 4):
++ requirements.append("enum34")
++
+ # If you add a new dep here you probably need to add it in the tox.ini as well
+ test_requirements = [
+ "pytest",
+