summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/diskcache/diskcache-3.1.0.ebuild')
-rw-r--r--dev-python/diskcache/diskcache-3.1.0.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/diskcache/diskcache-3.1.0.ebuild b/dev-python/diskcache/diskcache-3.1.0.ebuild
deleted file mode 100644
index 9e00a673ba04..000000000000
--- a/dev-python/diskcache/diskcache-3.1.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_6 )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-HOMEPAGE="http://www.grantjenks.com/docs/diskcache/"
-DESCRIPTION="Disk and file backed cache"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/django[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-"
-
-python_compile_all() {
- if use doc; then
- emake -C docs html
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
-
-python_test() {
- nosetests -v || die "failed with ${PYTHON}"
-}