summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/docopt/docopt-0.6.2.ebuild')
-rw-r--r--dev-python/docopt/docopt-0.6.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/docopt/docopt-0.6.2.ebuild b/dev-python/docopt/docopt-0.6.2.ebuild
new file mode 100644
index 000000000000..8151b4ae73e8
--- /dev/null
+++ b/dev-python/docopt/docopt-0.6.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pythonic argument parser, that will make you smile"
+HOMEPAGE="https://pypi.python.org/pypi/docopt https://github.com/docopt/docopt"
+SRC_URI="
+ mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ https://github.com/docopt/docopt/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="amd64 arm x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+# not implemented in this version, git already has it
+RESTRICT=test
+
+python_test() {
+ esetup.py test
+}