summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jenkins-webapi')
-rw-r--r--dev-python/jenkins-webapi/Manifest2
-rw-r--r--dev-python/jenkins-webapi/files/local_jenkins_war.patch12
-rw-r--r--dev-python/jenkins-webapi/files/tests_py27.patch7
-rw-r--r--dev-python/jenkins-webapi/jenkins-webapi-0.3.2.ebuild50
-rw-r--r--dev-python/jenkins-webapi/jenkins-webapi-0.4.0-r1.ebuild47
-rw-r--r--dev-python/jenkins-webapi/metadata.xml16
6 files changed, 134 insertions, 0 deletions
diff --git a/dev-python/jenkins-webapi/Manifest b/dev-python/jenkins-webapi/Manifest
new file mode 100644
index 000000000000..353444b1171a
--- /dev/null
+++ b/dev-python/jenkins-webapi/Manifest
@@ -0,0 +1,2 @@
+DIST jenkins-webapi-0.3.2.tar.gz 14831 SHA256 8f67d86c1f95edb79928af9b3b7c60ef9a63bfbfd19b6fe0a892ef4039f25500 SHA512 2ac59c90bba48406cc9fe5595505d5836eab1147869fbc8c06577767891d37904bffa5516316af0cb25f7f9193ae5277c0219ecc9daf5e0efa093fd449d1f4f0 WHIRLPOOL e4562a1857d7c526aec8c5ecc35f6a0644c48bf69fad4bdfef20f0708fdc0dfb5595c428acdc03e1df02c3d21669d47c89e0f3a99c1ee09a9741f9e21ab83b48
+DIST jenkins-webapi-0.4.0.tar.gz 16149 SHA256 7515b1e0503e07d50088e32205873146eda3b1132d8a6508e28f4e935c41e8b2 SHA512 ae40366e6fb6414391287ffa42ec92fba1971f070ac718d521c5b10f6e47d14ceea15a8c71f559380356530fdb2f826e08a6c611813b407dad73dab39fcddfeb WHIRLPOOL 30abf44c7d1ec6884baa3481c9d2f234f46f812d5ee6a8d9e49de8bc367ffef9c58f7653dcd30c24a308372cb8f6211e51f40e441e17f9ef15abd222de5d775b
diff --git a/dev-python/jenkins-webapi/files/local_jenkins_war.patch b/dev-python/jenkins-webapi/files/local_jenkins_war.patch
new file mode 100644
index 000000000000..c41f5bb51ce3
--- /dev/null
+++ b/dev-python/jenkins-webapi/files/local_jenkins_war.patch
@@ -0,0 +1,12 @@
+--- tests/install.py.orig 2014-11-23 21:21:29.000000000 +0100
++++ tests/install.py 2015-01-28 18:29:42.750933314 +0100
+@@ -23,7 +23,7 @@
+ self.destdir = destdir
+
+ self.logfile = logfile if logfile else pjoin(self.destdir, 'jenkins.log')
+- self.jenkinswar = pjoin(self.destdir, 'jenkins.war')
++ self.jenkinswar = pjoin('/opt/jenkins', 'jenkins.war')
+ self.jenkinscli = pjoin(self.destdir, 'jenkins-cli.jar')
+ self.homedir = pjoin(self.destdir, 'home')
+
+
diff --git a/dev-python/jenkins-webapi/files/tests_py27.patch b/dev-python/jenkins-webapi/files/tests_py27.patch
new file mode 100644
index 000000000000..5a6e8c9ddf69
--- /dev/null
+++ b/dev-python/jenkins-webapi/files/tests_py27.patch
@@ -0,0 +1,7 @@
+--- tests/conftest.py.orig 2014-11-23 21:21:29.000000000 +0100
++++ tests/conftest.py 2015-01-28 18:37:25.388067816 +0100
+@@ -1,3 +1,4 @@
++# -*- coding: utf-8 -*-
+ import re
+ import time
+ import pytest
diff --git a/dev-python/jenkins-webapi/jenkins-webapi-0.3.2.ebuild b/dev-python/jenkins-webapi/jenkins-webapi-0.3.2.ebuild
new file mode 100644
index 000000000000..5b7490481cad
--- /dev/null
+++ b/dev-python/jenkins-webapi/jenkins-webapi-0.3.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for interacting with the Jenkins CI server"
+HOMEPAGE="https://github.com/gvalkov/jenkins-webapi"
+SRC_URI="https://github.com/gvalkov/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/requests-2.4.3[${PYTHON_USEDEP}]"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-util/jenkins-bin
+ >=dev-python/pytest-2.6.3[${PYTHON_USEDEP}]
+ >=dev-python/termcolor-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cov-1.8.0[${PYTHON_USEDEP}]
+ >=dev-python/httmock-1.2.2[${PYTHON_USEDEP}] )
+ doc? (
+ >=dev-python/sphinx-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/alabaster-0.6.1[${PYTHON_USEDEP}] )
+ "
+
+PATCHES=(
+ "${FILESDIR}"/local_jenkins_war.patch
+ "${FILESDIR}"/tests_py27.patch
+ )
+
+python_test() {
+ emake test
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/jenkins-webapi/jenkins-webapi-0.4.0-r1.ebuild b/dev-python/jenkins-webapi/jenkins-webapi-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..acadf5dce8b5
--- /dev/null
+++ b/dev-python/jenkins-webapi/jenkins-webapi-0.4.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for interacting with the Jenkins CI server"
+HOMEPAGE="https://github.com/gvalkov/jenkins-webapi"
+SRC_URI="http://dev.gentoo.org/~idella4/tarballs/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+RESTRICT="mirror"
+
+RDEPEND=">=dev-python/requests-2.4.3[${PYTHON_USEDEP}]"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-util/jenkins-bin
+ >=dev-python/pytest-2.6.3[${PYTHON_USEDEP}]
+ >=dev-python/termcolor-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cov-1.8.0[${PYTHON_USEDEP}]
+ >=dev-python/httmock-1.2.2[${PYTHON_USEDEP}] )
+ doc? (
+ >=dev-python/sphinx-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/alabaster-0.6.1[${PYTHON_USEDEP}] )
+ "
+PATCHES=( "${FILESDIR}"/local_jenkins_war.patch )
+
+python_test() {
+ emake test
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/jenkins-webapi/metadata.xml b/dev-python/jenkins-webapi/metadata.xml
new file mode 100644
index 000000000000..469d770d7eb8
--- /dev/null
+++ b/dev-python/jenkins-webapi/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>idella4@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>hydrapolic@gmail.com</email>
+ <name>Tomas Mozes</name>
+ <description>Proxy maintainer and target for any bugs</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">gvalkov/jenkins-webapi</remote-id>
+ </upstream>
+</pkgmetadata>