summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/parse')
-rw-r--r--dev-python/parse/Manifest1
-rw-r--r--dev-python/parse/parse-1.20.0.ebuild17
2 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/parse/Manifest b/dev-python/parse/Manifest
index 3c7954b6cf4f..3976ccc8f287 100644
--- a/dev-python/parse/Manifest
+++ b/dev-python/parse/Manifest
@@ -1 +1,2 @@
DIST parse-1.19.1.gh.tar.gz 26732 BLAKE2B 15a1a11d9ca5c93a07848db4acdae1b9b489e3366f3dcbdcbae06a22b2bc8183fd266106dec5b975be8fd6926ee29d9ee4850db8d8504b8fc489bee82c7f0492 SHA512 f3fd067cbe6f30f0e61297f471dd7eb183d351ca60bf5a4dfd31cf0775988ecea6dfdf3f0ecd23dbe9fb3f8be3f5c1b824af660074589cb3b289658d0af898fa
+DIST parse-1.20.0.tar.gz 28871 BLAKE2B a6635641cb780c246053ddd7ecd397e994964086d3e5191356e425bb837b0e1c201c6b4e92755b4c4351589ff9055826964fa9eaac756e98bac90766a4703e06 SHA512 40ba63f62138c2273ec9bb603b7d8f74b471d9b143a49062a0f9979f8d84a7acce9d56ac046d38c6900fe07e9b5b3fdd3de7f2e78708e85234ec56b86410b14a
diff --git a/dev-python/parse/parse-1.20.0.ebuild b/dev-python/parse/parse-1.20.0.ebuild
new file mode 100644
index 000000000000..f8bf48bd5f04
--- /dev/null
+++ b/dev-python/parse/parse-1.20.0.ebuild
@@ -0,0 +1,17 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="Parse strings using a specification based on the Python format() syntax"
+HOMEPAGE="https://github.com/r1chardj0n3s/parse/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+distutils_enable_tests pytest