summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyechonest/pyechonest-9.0.0.ebuild')
-rw-r--r--dev-python/pyechonest/pyechonest-9.0.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pyechonest/pyechonest-9.0.0.ebuild b/dev-python/pyechonest/pyechonest-9.0.0.ebuild
new file mode 100644
index 000000000000..2789ead3a04f
--- /dev/null
+++ b/dev-python/pyechonest/pyechonest-9.0.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to The Echo Nest APIs"
+HOMEPAGE="http://echonest.github.com/pyechonest/"
+SRC_URI="https://github.com/echonest/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ sed -e "s/, 'sphinx.ext.intersphinx'//" -i doc/source/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}