summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyramid')
-rw-r--r--dev-python/pyramid/Manifest4
-rw-r--r--dev-python/pyramid/metadata.xml8
-rw-r--r--dev-python/pyramid/pyramid-1.5.1.ebuild46
-rw-r--r--dev-python/pyramid/pyramid-1.5.2.ebuild46
-rw-r--r--dev-python/pyramid/pyramid-1.5.4.ebuild46
-rw-r--r--dev-python/pyramid/pyramid-1.5.7.ebuild46
6 files changed, 196 insertions, 0 deletions
diff --git a/dev-python/pyramid/Manifest b/dev-python/pyramid/Manifest
new file mode 100644
index 000000000000..112ec9f84eab
--- /dev/null
+++ b/dev-python/pyramid/Manifest
@@ -0,0 +1,4 @@
+DIST pyramid-1.5.1.tar.gz 2401767 SHA256 2fe0b4012f10444682acc0df3b9cb85c7cfff2508ba5cbe6db83f5f14b510d86 SHA512 70b04111020d0f02ef21c52c44d7b6a5e78d198daee0068921df048bcae8b07567aee05d57f1a9e7329ef418116a0f7682aee30c6f785a4d1ec847e2519e7cc5 WHIRLPOOL 16e17ccba24f6a76c4ef0f2e361580e832c6450f453f88229bf1204cd123719e08e8565bb46d8b0bef5b395af2dfa87cb7ac7a9dc0dc9a0cc2d019490716e151
+DIST pyramid-1.5.2.tar.gz 2422156 SHA256 12057e63c9c99f88bc71af12f00a5e2c934221122baf582c7365361cba45bdcc SHA512 531d68fb480cf1420e069025537968abebc17bed98bf25e9993b8c744a12c5031df4b9b09e6f775bb1176f305f2e2c8ddb176ff43d1b34a10f2181df74fac8b8 WHIRLPOOL 785706946338dee67c7472c8d0b97fea86b8695d2efe7da93c483acf6476e5501269732a24b1cec50e1b9bf723edab44e437785cfd833bd3263c0207bc4f3ad9
+DIST pyramid-1.5.4.tar.gz 2678373 SHA256 39c48570595cfdb38227552a9e2858e62cc45ced4db94cf9b136cd823acda19f SHA512 2c2f9f42c64a4c184bb743005f7ba2f7fce2409e35c7db3e683852f6c93e44dea26d082c88727a44bdde253e6648cfb95169f6f5615d2d17bccd4b4113e0361f WHIRLPOOL bebd849ce1a116f7b04d2b5f3fb71ab5fe964e50a16a576d91c5509f7dd3f5312b4d9d174d0369d2d7db2f2c363e8caa594bb23249f59b11bfd80eed9e2d6245
+DIST pyramid-1.5.7.tar.gz 2678474 SHA256 c1302d5ccb6833e8794ddb649aa9bb64d86c05adb127c93e329f8863907449b4 SHA512 32b0d4b85bf0f471b7c08ac7353f2859284ee7bb2451b68429074fb5f954e0e02d7bc4bdd86f843d6a5304b56a418e698d614806bbfd09dda9a608db88c25949 WHIRLPOOL 2c12aab5e91eede072f0b45b510699f048f9848753cf134e21dcb775b0f2fa96c815d1573cd11b67afa76f401bdab230b67fe1a24a8a861708309d8b26308619
diff --git a/dev-python/pyramid/metadata.xml b/dev-python/pyramid/metadata.xml
new file mode 100644
index 000000000000..98d5d9c09f4c
--- /dev/null
+++ b/dev-python/pyramid/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">pyramid</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyramid/pyramid-1.5.1.ebuild b/dev-python/pyramid/pyramid-1.5.1.ebuild
new file mode 100644
index 000000000000..0329247d1e49
--- /dev/null
+++ b/dev-python/pyramid/pyramid-1.5.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+RESTRICT="test" # Can't package dependencies
+
+DESCRIPTION="A small open source Python web framework"
+HOMEPAGE="http://www.pylonsproject.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+#IUSE="test"
+# tests would pull in dev-python/zope-deprecation with its deps - not a good idea
+
+RDEPEND="
+ dev-python/chameleon[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/webob[${PYTHON_USEDEP}]
+ dev-python/repoze-lru[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ dev-python/translationstring[${PYTHON_USEDEP}]
+ dev-python/pastedeploy[${PYTHON_USEDEP}]
+ dev-python/venusian[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "
+ #test? ( dev-python/webtest[${PYTHON_USEDEP}]
+ # dev-python/nose[${PYTHON_USEDEP}]
+ # dev-python/coverage[${PYTHON_USEDEP}]
+ # dev-python/virtualenv[${PYTHON_USEDEP}]
+ # )
+ #"
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/pyramid/pyramid-1.5.2.ebuild b/dev-python/pyramid/pyramid-1.5.2.ebuild
new file mode 100644
index 000000000000..5c6c05219418
--- /dev/null
+++ b/dev-python/pyramid/pyramid-1.5.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+RESTRICT="test" # Can't package dependencies
+
+DESCRIPTION="A small open source Python web framework"
+HOMEPAGE="http://www.pylonsproject.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+#IUSE="test"
+# tests would pull in dev-python/zope-deprecation with its deps - not a good idea
+
+RDEPEND="
+ dev-python/chameleon[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/webob[${PYTHON_USEDEP}]
+ dev-python/repoze-lru[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ dev-python/translationstring[${PYTHON_USEDEP}]
+ dev-python/pastedeploy[${PYTHON_USEDEP}]
+ dev-python/venusian[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "
+ #test? ( dev-python/webtest[${PYTHON_USEDEP}]
+ # dev-python/nose[${PYTHON_USEDEP}]
+ # dev-python/coverage[${PYTHON_USEDEP}]
+ # dev-python/virtualenv[${PYTHON_USEDEP}]
+ # )
+ #"
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/pyramid/pyramid-1.5.4.ebuild b/dev-python/pyramid/pyramid-1.5.4.ebuild
new file mode 100644
index 000000000000..5c6c05219418
--- /dev/null
+++ b/dev-python/pyramid/pyramid-1.5.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+RESTRICT="test" # Can't package dependencies
+
+DESCRIPTION="A small open source Python web framework"
+HOMEPAGE="http://www.pylonsproject.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+#IUSE="test"
+# tests would pull in dev-python/zope-deprecation with its deps - not a good idea
+
+RDEPEND="
+ dev-python/chameleon[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/webob[${PYTHON_USEDEP}]
+ dev-python/repoze-lru[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ dev-python/translationstring[${PYTHON_USEDEP}]
+ dev-python/pastedeploy[${PYTHON_USEDEP}]
+ dev-python/venusian[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "
+ #test? ( dev-python/webtest[${PYTHON_USEDEP}]
+ # dev-python/nose[${PYTHON_USEDEP}]
+ # dev-python/coverage[${PYTHON_USEDEP}]
+ # dev-python/virtualenv[${PYTHON_USEDEP}]
+ # )
+ #"
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/pyramid/pyramid-1.5.7.ebuild b/dev-python/pyramid/pyramid-1.5.7.ebuild
new file mode 100644
index 000000000000..5c6c05219418
--- /dev/null
+++ b/dev-python/pyramid/pyramid-1.5.7.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+RESTRICT="test" # Can't package dependencies
+
+DESCRIPTION="A small open source Python web framework"
+HOMEPAGE="http://www.pylonsproject.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+#IUSE="test"
+# tests would pull in dev-python/zope-deprecation with its deps - not a good idea
+
+RDEPEND="
+ dev-python/chameleon[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/webob[${PYTHON_USEDEP}]
+ dev-python/repoze-lru[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ dev-python/translationstring[${PYTHON_USEDEP}]
+ dev-python/pastedeploy[${PYTHON_USEDEP}]
+ dev-python/venusian[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "
+ #test? ( dev-python/webtest[${PYTHON_USEDEP}]
+ # dev-python/nose[${PYTHON_USEDEP}]
+ # dev-python/coverage[${PYTHON_USEDEP}]
+ # dev-python/virtualenv[${PYTHON_USEDEP}]
+ # )
+ #"
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}