summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-xvfb/pytest-xvfb-3.0.0.ebuild')
-rw-r--r--dev-python/pytest-xvfb/pytest-xvfb-3.0.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pytest-xvfb/pytest-xvfb-3.0.0.ebuild b/dev-python/pytest-xvfb/pytest-xvfb-3.0.0.ebuild
new file mode 100644
index 000000000000..e9a2d47ef72d
--- /dev/null
+++ b/dev-python/pytest-xvfb/pytest-xvfb-3.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="tk"
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pytest plugin to run Xvfb for tests"
+HOMEPAGE="https://pypi.org/project/pytest-xvfb/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pyvirtualdisplay[${PYTHON_USEDEP}]
+ x11-base/xorg-server[xvfb]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p xvfb --runpytest=subprocess
+}