summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-engineio/python-engineio-0.8.6.ebuild')
-rw-r--r--dev-python/python-engineio/python-engineio-0.8.6.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/python-engineio/python-engineio-0.8.6.ebuild b/dev-python/python-engineio/python-engineio-0.8.6.ebuild
new file mode 100644
index 000000000000..53e64a8376b0
--- /dev/null
+++ b/dev-python/python-engineio/python-engineio-0.8.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN=""
+DESCRIPTION="Python implementation of the Engine.IO realtime server."
+HOMEPAGE="https://${PN}.readthedocs.org/ https://github.com/miguelgrinberg/${PN}/ https://pypi.python.org/pypi/${PN}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# pypi tarball does not contain tests
+RESTRICT="test"
+
+src_prepare() {
+ sed -e 's:pbr<1.7.0:pbr:' -i setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ esetup.py test || die
+}