summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-yadis/python-yadis-1.1.0-r2.ebuild')
-rw-r--r--dev-python/python-yadis/python-yadis-1.1.0-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/python-yadis/python-yadis-1.1.0-r2.ebuild b/dev-python/python-yadis/python-yadis-1.1.0-r2.ebuild
new file mode 100644
index 000000000000..a914353dae7f
--- /dev/null
+++ b/dev-python/python-yadis/python-yadis-1.1.0-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Yadis service discovery library"
+HOMEPAGE="http://www.openidenabled.com/yadis/libraries/python/"
+SRC_URI="http://www.openidenabled.com/resources/downloads/python-openid/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/elementtree[${PYTHON_USEDEP}]
+ dev-python/python-urljr[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( >=dev-python/pyflakes-0.2.1[${PYTHON_USEDEP}] )"
+
+# Fix broken test
+PATCHES=( "${FILESDIR}/${P}-gentoo-test.patch" )
+
+python_test() {
+ ./admin/runtests
+ einfo "The pyflake output about XML* redefinitions can be safely ignored"
+}