summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/toro/toro-1.0.1.ebuild')
-rw-r--r--dev-python/toro/toro-1.0.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/toro/toro-1.0.1.ebuild b/dev-python/toro/toro-1.0.1.ebuild
new file mode 100644
index 000000000000..195bd0f7796e
--- /dev/null
+++ b/dev-python/toro/toro-1.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Synchronization primitives for Tornado coroutines"
+HOMEPAGE="https://github.com/ajdavis/toro/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="examples test"
+
+RDEPEND="
+ virtual/python-futures[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+PATCHES=(
+ "${FILESDIR}"/${P}-no-test-install.patch
+)
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}