summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/twisted-pair/twisted-pair-15.1.0.ebuild')
-rw-r--r--dev-python/twisted-pair/twisted-pair-15.1.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/twisted-pair/twisted-pair-15.1.0.ebuild b/dev-python/twisted-pair/twisted-pair-15.1.0.ebuild
new file mode 100644
index 000000000000..2c374df62788
--- /dev/null
+++ b/dev-python/twisted-pair/twisted-pair-15.1.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit twisted-r1
+
+DESCRIPTION="Twisted low-level networking"
+
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="=dev-python/twisted-core-${TWISTED_RELEASE}*[${PYTHON_USEDEP}]
+ dev-python/eunuchs[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+# https://twistedmatrix.com/trac/ticket/7433
+PATCHES=( "${FILESDIR}"/14.0.0-tests.patch )