summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/PyGithub/Manifest1
-rw-r--r--dev-python/PyGithub/PyGithub-1.46.ebuild35
-rw-r--r--dev-python/deprecated/deprecated-1.2.7.ebuild2
-rw-r--r--dev-python/pyjwt/files/pyjwt-1.7.1-ecdsa-fix.patch27
-rw-r--r--dev-python/pyjwt/pyjwt-1.7.1-r1.ebuild56
-rw-r--r--dev-python/sure/sure-1.4.11.ebuild2
-rw-r--r--dev-python/wrapt/wrapt-1.11.2-r1.ebuild2
7 files changed, 122 insertions, 3 deletions
diff --git a/dev-python/PyGithub/Manifest b/dev-python/PyGithub/Manifest
index f5de2382bbdb..8fee48d24b44 100644
--- a/dev-python/PyGithub/Manifest
+++ b/dev-python/PyGithub/Manifest
@@ -1,2 +1,3 @@
DIST PyGithub-1.44.1.gh.tar.gz 2866013 BLAKE2B 90ca7f21fe0031c6cc6d50f54facd7c086037f942f9595e78a3b1a0fe0d21b6bc587f07b63152afabbaa2f38d165b8014600cb195207519a16e3e05fb9bfbcff SHA512 87b6c05f3bbfa463995b67d0bb257700e8c67050dd291c60737a84c4e8bc6bcbde1c0e2add98ec38174c55f2c21abcf4c46bba8be752d132d7e63e423ab6fd1e
DIST PyGithub-1.45.gh.tar.gz 2881912 BLAKE2B 0117608298f6b5d522f451382ea058a9dc507dbf15b31542f4039da8105cf0cb002ac17b5c5c321e465f97dce20699de0d319010c478a5c9d30529e885516e42 SHA512 24ff3c75f5578f5e0df59fa1a02511747857984d7bd4ae1b3d0a3b41a0eee79df9732d39ee5026978b70a71746826e92f27cc44b8362b6bd3e7dd4edb1654acd
+DIST PyGithub-1.46.gh.tar.gz 2882667 BLAKE2B a65a359750c146947b69ff72a4775f6f1532420c3d15e0d7df34c69c3c552aa201740c1ea2cff2dd40daddf7cdc7743b4354698e1bc701f175a5f7dcfc83dd97 SHA512 1c03920434491b279e1709550a658ff125c0d91390160b1de5e5fadf5cf5eeb722477fd913f47ec686cce052a8c34d916de753ea36fecb227d955e60d064a0b6
diff --git a/dev-python/PyGithub/PyGithub-1.46.ebuild b/dev-python/PyGithub/PyGithub-1.46.ebuild
new file mode 100644
index 000000000000..884e61e5f2d2
--- /dev/null
+++ b/dev-python/PyGithub/PyGithub-1.46.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to access the Github API v3"
+HOMEPAGE="https://github.com/PyGithub/PyGithub/"
+# Use github since pypi is missing test data
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/deprecated[${PYTHON_USEDEP}]
+ dev-python/pyjwt[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.0[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/httpretty-0.9.6[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ "${EPYTHON}" -m unittest -v tests.AllTests || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/deprecated/deprecated-1.2.7.ebuild b/dev-python/deprecated/deprecated-1.2.7.ebuild
index 1c28971d7adf..c5ef661a2a3f 100644
--- a/dev-python/deprecated/deprecated-1.2.7.ebuild
+++ b/dev-python/deprecated/deprecated-1.2.7.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{6,7}} )
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
inherit distutils-r1
DESCRIPTION="Python @deprecated decorator to deprecate old API"
diff --git a/dev-python/pyjwt/files/pyjwt-1.7.1-ecdsa-fix.patch b/dev-python/pyjwt/files/pyjwt-1.7.1-ecdsa-fix.patch
new file mode 100644
index 000000000000..ebd9236c7994
--- /dev/null
+++ b/dev-python/pyjwt/files/pyjwt-1.7.1-ecdsa-fix.patch
@@ -0,0 +1,27 @@
+From 36a3f9bd0cc7029e5150b1931efbd62da975e8b9 Mon Sep 17 00:00:00 2001
+From: StefanBruens <stefan.bruens@rwth-aachen.de>
+Date: Mon, 21 Oct 2019 02:07:19 +0200
+Subject: [PATCH] Catch BadSignatureError raised by ecdsa 0.13.3 on
+ verification errors (#448)
+
+The new ecdsa no longer uses AssertionError when the signature is too long.
+This happens in the test suite, where "123" is appended to the signature.
+
+Fixes #447
+---
+ jwt/contrib/algorithms/py_ecdsa.py | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/jwt/contrib/algorithms/py_ecdsa.py b/jwt/contrib/algorithms/py_ecdsa.py
+index bf0dea5..f1170a6 100644
+--- a/jwt/contrib/algorithms/py_ecdsa.py
++++ b/jwt/contrib/algorithms/py_ecdsa.py
+@@ -56,5 +56,7 @@ def verify(self, msg, key, sig):
+ try:
+ return key.verify(sig, msg, hashfunc=self.hash_alg,
+ sigdecode=ecdsa.util.sigdecode_string)
+- except AssertionError:
++ # ecdsa <= 0.13.2 raises AssertionError on too long signatures,
++ # ecdsa >= 0.13.3 raises BadSignatureError for verification errors.
++ except (AssertionError, ecdsa.BadSignatureError):
+ return False
diff --git a/dev-python/pyjwt/pyjwt-1.7.1-r1.ebuild b/dev-python/pyjwt/pyjwt-1.7.1-r1.ebuild
new file mode 100644
index 000000000000..1cb2f6e14153
--- /dev/null
+++ b/dev-python/pyjwt/pyjwt-1.7.1-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
+
+inherit distutils-r1 eutils
+
+MY_PN="PyJWT"
+DESCRIPTION="JSON Web Token implementation in Python"
+HOMEPAGE="https://github.com/progrium/pyjwt https://pypi.org/project/PyJWT/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}"/${MY_PN}-${PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=""
+DEPEND="
+ test? (
+ >=dev-python/cryptography-1.4.0[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ find . -name '__pycache__' -prune -exec rm -rf {} + || die
+ find . -name '*.pyc' -delete || die
+
+ # enables coverage, we don't need that
+ rm setup.cfg || die
+ # kill tests using pycrypto that break with pycryptodome
+ sed -i -e '/has_pycrypto/s:True:False:' \
+ tests/contrib/test_algorithms.py || die
+
+ local PATCHES=(
+ "${FILESDIR}"/pyjwt-1.7.1-ecdsa-fix.patch
+ )
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ elog "Available optional features:"
+ optfeature "cryptography" dev-python/cryptography
+ optfeature "flake8" dev-python/flake8{,-import-order}
+
+ ewarn "flake8 feature requires 'pep8-naming' which is not packaged yet"
+}
diff --git a/dev-python/sure/sure-1.4.11.ebuild b/dev-python/sure/sure-1.4.11.ebuild
index d30b2728f231..15447975e25e 100644
--- a/dev-python/sure/sure-1.4.11.ebuild
+++ b/dev-python/sure/sure-1.4.11.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
inherit distutils-r1
diff --git a/dev-python/wrapt/wrapt-1.11.2-r1.ebuild b/dev-python/wrapt/wrapt-1.11.2-r1.ebuild
index 46b0288179ff..8260fc728419 100644
--- a/dev-python/wrapt/wrapt-1.11.2-r1.ebuild
+++ b/dev-python/wrapt/wrapt-1.11.2-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
inherit distutils-r1