summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/diagnostic_aggregator/diagnostic_aggregator-9999.ebuild')
-rw-r--r--dev-ros/diagnostic_aggregator/diagnostic_aggregator-9999.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-ros/diagnostic_aggregator/diagnostic_aggregator-9999.ebuild b/dev-ros/diagnostic_aggregator/diagnostic_aggregator-9999.ebuild
index 34ba1bbe98c4..76db5fae27db 100644
--- a/dev-ros/diagnostic_aggregator/diagnostic_aggregator-9999.ebuild
+++ b/dev-ros/diagnostic_aggregator/diagnostic_aggregator-9999.ebuild
@@ -23,10 +23,11 @@ RDEPEND="
dev-ros/bondcpp
dev-libs/boost:=
dev-libs/console_bridge:=
+ dev-ros/bondpy[${PYTHON_SINGLE_USEDEP}]
"
DEPEND="${RDEPEND}
dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- test? ( dev-ros/rostest )"
+ test? ( dev-ros/rostest[${PYTHON_SINGLE_USEDEP}] )"
src_test() {
export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"