summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rosgraph/rosgraph-9999.ebuild')
-rw-r--r--dev-ros/rosgraph/rosgraph-9999.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-ros/rosgraph/rosgraph-9999.ebuild b/dev-ros/rosgraph/rosgraph-9999.ebuild
index 5371ed906b58..0266daff9c69 100644
--- a/dev-ros/rosgraph/rosgraph-9999.ebuild
+++ b/dev-ros/rosgraph/rosgraph-9999.ebuild
@@ -15,7 +15,11 @@ SLOT="0"
IUSE=""
RDEPEND="
- dev-python/netifaces[${PYTHON_USEDEP}]
- dev-python/rospkg[${PYTHON_USEDEP}]"
+ $(python_gen_cond_dep "dev-python/netifaces[\${PYTHON_USEDEP}]")
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+"
DEPEND="${RDEPEND}
- test? ( dev-python/mock[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )"
+ test? (
+ $(python_gen_cond_dep "dev-python/mock[\${PYTHON_USEDEP}]")
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ )"